Showing results for 
Search instead for 
Did you mean: 

ProArt x670e m2 problem (slot 4) with expo on.

Level 9

Hi All,

Had a m2 slot (slot4) disappearing issue when turning on EXPO. and also instability when plugging in USB drives/hdd.

Just want to check with this forum if anyone had the same issue? Is it a motherboard issue? CPU? Chipset issue? Or bios problem?

Its a long post and thanks for reading.


Specs: Asus ProArt x670e, 7800x3d,

32GB 6000MHz CL32 GSkill Trident Z5 Neo. (On QVL) 2x16gb.

Slot 1, 2TB WD gen 4.

Slot 2 and 3, two 512GB Micron gen4.

Slot 4, 1TB Samsung gen3.

Windows 11 Pro.

RAM tested with windows 11 pro memory diagnostics and reported no error.


Below are the tests I had done on different BIOS versions.

For the below tests:

The only changes from default bios is expo1 on/off except 1101 where I lowered the RAM frequency to test.

0805 bios, Once tuned on expo, 4th SSD not detected. Not showing up in bios and windows. Took out slot 3 micron SSD, detected slot 4 samsung SSD with expo on. Proofed slot 4 working. Placed samsung SSD into slot 3, SSD detected no problem. Ruled out SSD and slot failure.

1101 bios, Same. Turned on expo1, 2, etc. Slot 4 will disappear. Once off expo, SSD will come back. (One incident to note is when I switch to expo off, the slot 4 SSD did not come back, slot 4 is not detected in bios. I then turned expo1 off, slot 4 SSD still did not came back. Turned expo on, slot 3 disappeared. However, after another reboot with expo off, all m2 slots appeared.)

Further test with expo 1 on, but keep reducing ram MHz to default 4800, slot 4 will not appear. Only when default back bios, slot 4 came back.


1202 bios Same, turn expo on, slot 4 SSD disappear. Off expo, slot 4 SSD appear.

One incident when I restart Windows and try to enter bios, it will not post. Restarted and enter bios, only 3 SSD detected but the expo is off. Turn off system, (AC wall); turn on AC power, all 4 drives detected.

I had ran cinebench r23 on 1101 and 1201 and the results are about 17000 MC and 1793 SC. 

(With the recent burning SoC iusse, I took the whole system to where i bought the parts,, they did a check and said cpu and motherboard not burnt. Was suspecting if any damages caused this instability since I am on 0805 and 1101.)


Bios 1202, EXPO off. RAM at 4800Hz default.

All 4 SSDs showing in Windows Explorer.

Plug in external USB HDD to copy some files into the SSDS, found that the slot 4 SSD is present, but could not write anything into it. Then it disappears.

Doing a restart cannot restore the SSD back in windows and bios no detect either.

Only power off the main(wall) brought it back.

This time with the 4 SSDs back in action, test by plugging in USB C drive into the back of the MB, and, still the same, could not write anything. Drive does not disappear in Windows Explorer. Went into disk management and try formatting the drive; but error.

Restarted PC. 4th SSD not present. Turn off main, power on, SSDs back again and writes No problem.


Update to bios 1303,

Turn on EXPO 2, ram at 6000mhz. 4th ssd missing. (Expected)

Plug in 2 USB hdd, and 1 USB thumb drive. Read write to all SSDs no issue.

Reboot, tried to went to BIOS to turn EXPO off. But could not. Manually pressed power key and get into BIOS.

In BIOS, disable the EXPO and reboot but this time cannot detect the 4th SSD.


So, it seems 4th SSD slot even when detected under expo disabled is rather unstable. Once plug in USB HDD or thumb drive , could cause SSD4 to not work and disappear.

X670e chipset problem ? Since it controls the pcie and usb lanes?


Just want to hear from the forum anyone facing the same issues with 4 SSDs populated on the same chipset or board or cpu? And how was the problem solved?

Appreciate any Asus tech to help please. Thanks.




Level 9

Anyone with suggestions or advice?

Thanks 😊 

Level 9

Hi, anyone who had an ASUS X670E board with a X3D processor and had 4 SSDs installed and had no issue with EXPO on?

No issue even when plugged in 2 or more USB thumb drives?


I am using the same board and many many usb devices plugged (via 4~5 hubs), usb works well, had not met any issues.

And 3 SSDs installed on my board, it seems at the time around BIOS 1101 released, sometimes one same SSD will missed in BIOS after reboot or cold boot randomly, which is installed at the slot between GPU and CPU, and I disabled fast boot in BIOS and fixed it. Hope this can help you.

BTW, just off topic, could you please check your GPU PCIE lanes on PCIE16X_1 slot? My GPU always runs on 8x on this board, and I can't find other people using this board for reference for a while, thanks !

Hi, thanks for your suggestion. But its a no Go.  Replied your question on your thread too.


Tested with default BIOS (F5); means EXPO off; cold start; Fastboot OFF.  Still same result.

SSD4 disappear and event ID11 when plugged in external USB SATA HDD.

Source: stornvme

Event ID: 11


Raidport4 and 5 errors.

Description: The driver detected a controller error on \Device\RaidPort5.


Anyway what SSDs and RAM you have?

Possible to share the MB revision?

The issues you met are weird, too. Maybe the MB is defective...

Just check the revision of my board is R1.03, brought at the end of Oct 2022.

Here are my specs:

SSD: two micron P3 series (one 500G, one 2000G), one GLOWAY 2T (can't find its name in english), slot4 is not used, I can test it for you in a while, since I am gonna send MB to RMA.

RAM: two sticks XPG running at 6000MHz (EXPO Tweaked + tightened timings)

CPU: Vsoc @ 1.25V VDDCR VDDIO @ 1.25V

Hi, thanks. 

Do let me know your results with 4th SSDs..

I think I am ready to send in my MB too. 

Inserted a Optane SSD to slot 4, and two USB sticks, EXPO on, no issue. Hmm.


Hi 0xc0cafe,

Thanks and appreciated for your help!

Looks like time to take out my ProArt MB and send it in!

Oh yes, do you mind to check your Event Viewer to check anything related to Event ID 11?

Raidport error, pasted below. (or like I described in the above posts.)

Source: stornvme

Event ID: 11

Raidport 4 and 5 errors.

Description: The driver detected a controller error on \Device\RaidPort5.



Level 9