Showing results for 
Search instead for 
Did you mean: 

ProArt X670E-CREATOR and QVL doesn't boot

Level 7

Hello, I have an issue with my ram. I got a QVL ram but it doesn't boot still.tried 1 and 2 slots and nothing happened. Ideally I need 128gb. I see there's no way to have 128 at the moment, should I expect it to change in the future?

ram: KF552C40BWK4-128

CPU: AMD Ryzen 9 7950X 4.5 GHz

Thank yo


Super Moderator

Hi there,

Does this behaviour occur after clearing CMOS? (follow instructions in the manual)

At complete operating defaults, the system should POST.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 10

Her ram not Support from this Board! Kingston does not support 128 GB (4 x 32 GB) on AMD X6xx platform or EXPO profile. Only Max. 64 GB (2 x 32 GB). The ASUS QVL Unfortunately, they are usually incorrect. 

Kingston FURY™ Beast DDR5 Memory - Memory – 8GB, 16GB, 32GB, 64GB, 128GB/4800MT/s, 5200MT/s, 5600MT/...

AMD Ryzen 9 7950X3D | ROG CROSSHAIR X670E EXTREME | ASUS TUF Gaming GeForce RTX 4090 OC | G.Skill F5-6000J3040G32GX2-TZ5N | WD Black SN850X | PHANTEKS Glacier One 360 T30 Gen2 | LG OLED42C27LA | Phanteks NV7 | Seasonic PRIME-TX-1300 | Windows 11 Pro.

Thank you 🙏 What ram would you recommend? I need at least 80gb of ram.

I also tried just installing 1 and 2 sticks.

Use the memory QVL and assort by 2x48GB kits. As already said, the kit you have there should operate at complete defaults (No EXPO).

If it doesn't, you may want to look into that first.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

The QVL is for EXPO. AM5 supports DDR5 3600MT for 2 DIMM Per Channel SR and DR configurations.



13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090