cancel
Showing results for 
Search instead for 
Did you mean: 

Pc wont start or POST anymore even though it just worked

JackytheChinese
Level 7

Hello this is my first time Posting here!

I Just build a new pc cause my old one wasnt enough for my designated usage.

I installed everything flashed the bios and installiert Windows. Even started to download steam etc to test a few games out.

But when i came back from the Toilette i saw my pc shut down.

When i tried to start it up again nothing.

I tried a few Things including cmos reset and removing exzessive parts but nothing helped.

Only the dekorativ light on the mobo is on nothing Else when i press the Power Button. I even tried to use the on Board pwr button.

Nothing starts up not even my aio or my gpu or case rgbs.

Following setup:

Ryzen 7950x3d cpu
Asus Prime x670e-pro wifi mobo
Rtx 3080 ti gpu
DDR5 6000mhz 64GB Vengence ram
2TB 990evo m2 ssd
360l aio cooler master


I hope someone can give me Suggestions for my Problem since i literally tried everything i knew and i need it for work asap.

341 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Nate152
Moderator

Hello JackytheChinese

What power supply are you using?

Try turning off the power supply switch, press and hold the case power button for 5 seconds to drain any leftover power.

Flip the psu switch on and try starting your pc.

 

View solution in original post

3 REPLIES 3

Nate152
Moderator

Hello JackytheChinese

What power supply are you using?

Try turning off the power supply switch, press and hold the case power button for 5 seconds to drain any leftover power.

Flip the psu switch on and try starting your pc.

 

Yea i also tried that Option i have a 1200w Platinun 80 by be quiet.

But still... nothing moves