Showing results for 
Search instead for 
Did you mean: 

My B650E-E hates Windows 11

Level 7

Hello fellow ROG owners.

I own a B650E-E motherboard with the latest bios(v1616) paired with a Ryzen7700x processor. A few weeks ago shortly after updating to 1616 I got a corruption related message while booting to Win11. When I restarted I found out that my PC would not boot to windows (installed on a SN850x nvme ssd) anymore. It was stuck immediately after the bios screen, with the Q error code "Ad".

I tried booting Win11 install from a USB, and got the same exact problem : a black screen and a Q code of "Ad". It would not boot even from a usb ! I tried other usb flash drives, usb ports, even redownloaded the Win11 iso, nothing worked... same error code and blank screen. I removed graphics cards, hard disks, I even purchased new memory modules, but to no avail.

Then I downloaded a Fedora Linux ISO. And that actually worked I was able to boot to Fedora's installation (Live environment). While there, I backed  everything up and installed Fedora on my nvme. Boot up and everything worked.  At this point I was happy that at least I had an OS that worked.

I started experimenting with the Bios Settings and discovered that by disabling :

Advanced\Trusted Computing\Security Device Support

I could boot to Win11 usb install, sadly however the install did not go forward as after entering the win product key, I was greeted with the "This PC cannot run this version of windows", probably because I disabled TPM with the above setting.

Any help will be appreciated


Best Regards






Level 17

Bit of an old article, but probably still works with the registry adjustments. Rufus used to offer these options but either Rufus has changed or the Win 11 ISO has been changed. I have no longer have those options, which were very convenient.

I also remember reading about issues with the 850X on these forums, so your issues might be caused by that drive. I think there might be a solution if that's it, but you might need to search for it. 


Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Level 7

Thank you for your reply. I removed the TPM2.0 requirements from Win11 installation using Rufus, and together with disabling Advanced\Trusted Computing\Security Device Support, I managed to install windows. But there still an issue with TPM and my build. I cannot boot (or install) windows when TPM is enabled... Is this a motherboard issue, cpu or both ?