Showing results for 
Search instead for 
Did you mean: 

MediaTek WiFi Adapter stops working during Counter Strike 2

Level 7


So I've been having an issue these past couple of weeks where the WiFi would completely stop working, but only when playing CS2. I've a b650e-f, with the MediaTek RZ608, with the latest drivers from this forum. Everything was working perfectly fine, until recently when this issue appeared. The only way to get Internet back is to disable the adapter and reeable it. This issue never comes, only during CS2. Anyone has any ideas?


Thanks 🙂


Super Moderator

Hello @zergoot,

is the behaviour the same using the validated driver from the support site?

You can try disabling power management settings from within Device Manager. Double click the WiFi adapter and to Power Management. Untick allow this computer to turn off this device to save power.


13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi 🙂

I have heard of power management solution, and it was disabled already 😞 Sadly, the problem persisted nonetheless. 

As for the drivers: I have had this problem with the driver downloaded by armoury crate (which is as far as I know the same as on the website, right?), and one of the newer versions that was in this thread on this very forum. I have since found an even newer version posted by the author, which version I will be trying out today. 

Edit: I have tried both the newest driver, and the driver from the support site. Neither worked 😞 Should I RMA? I have tried Helldivers 2 on the newest driver, and it worked perfectly fine. Seems to me that CS2 is the only game where this happens.

Edit: It even happens to the Ethernet adapter... What... the... hell??