cancel
Showing results for 
Search instead for 
Did you mean: 

Expo not working on X670E Hero with Kingston Fury Beast 6000 (SK-Hynix)

Cr
Level 7
Hi, first of all, sorry for my bad English, it's a loooong time ago since I left school.
I hope someone here can help me to solve my problems.
my Hardware:
CPU: Ryzen 9 7900X
Cooler: Noctua NH-D15S chromax.black
Mainboard: ASUS ROG Crosshair X670E Hero with UEFI 0705
RAM: Kingston Fury Beast RGB DDR5 6000 cl36 (I know not at the QVL List, but they got the SK-Hynix Chips)
GPU: RX6900XTXH (XFX Limited Black Gaming)
PSU: Seasonic TX-850
SSD: 1TB WD SN850 Black & 2TB WD SN850 Black
CPU, Board and Ram are the new parts of my Rig.

When I try to run the EXPO Profiles the Board "hangs" for around 5 Minutes at the 15 State on the Q-LED, then it reboot and get me a Post Error and I had to press F1 to get in the UEFI. I can't even change my Ram to DDR 5 5000 or higher manual. I changed the Ram Sticks from A2 to B2 and B2 to A2 still won't work. Even with only 1 Stick same issue.
2,880 Views
7 REPLIES 7

LainX84
Level 9
I have an ASUS ROG Crosshair X670E Hero with BIOS 0705 and as memories I have 2 Kingston FURY Beast DDR5 banks (the KIT has code KF556C36BBEAK2-32) and currently I have enabled EXPO Mode and it works perfectly.

96114

Cr
Level 7
different Kit here KF560C36BBEAK2-32

Cr
Level 7
OK, new Ram - G.Skill Trident Z5 Neo (F5-6000J3038F16GX2-TZ5NR) still no Expo possible.

Cr@zed^ wrote:
OK, new Ram - G.Skill Trident Z5 Neo (F5-6000J3038F16GX2-TZ5NR) still no Expo possible.


I'm using the same ram kit on bios 0705. I have no issues running expo.

Cr
Level 7
Nice to read, but didn't help me 🙂

planetbeing
Level 7
Usually these memory problems can be solved by setting UCLK=MEMCLK in the BIOS settings. Unfortunately, the BIOS sets UCLK=MEMCLK/2 for speeds greater than or equal to 6000 MT/s by default and that never seems to work.

Cr
Level 7
Update:
I ordered now a Ryzen 9 7950X and all is fine. Looks like the 7900X was faulty.