cancel
Showing results for 
Search instead for 
Did you mean: 

DDR5 AMD system 4800 MHz RAM issue

ruxima
Level 8

Hello, I have set up a DDR5 AMD system. However, I have an issue related to the RAM. The RAM modules are not functioning above 4800 MHz. I have tried Expo 1, Expo 2, and other profiles, but none of them worked. I also attempted manual overclocking, but it didn't yield any results. Thinking that there might be a problem with my motherboard, I sent it for service and had it replaced. I also changed the RAM modules and purchased ones that were listed as compatible with the motherboard. However, I am still facing the same issue. I am unable to enter the BIOS screen with any speed settings above 4800 MHz. The PC only works when the RAM is set to 4800 MHz. Could the issue be with the memory controller of the processor?  (I have tried all available BIOS versions for the motherboard).

Asus Rog Strix X670E-E

Ryzen 7900x3D

RAM: Ram GSKILL Trident Z Neo F5-6000J3238F16GX2-TZ5NR 2x16 32GB ( A2, B2)

MSI 360mm lıquıd cooler

1050w 80+ plat psu

 

2,082 Views
22 REPLIES 22

Not sure if the cpu matters, but...

For me, i ran a 7600x around october, then a 7950x, now a 7800x3d. All where fine. 

 Ddr5 is a bit "flimsy/touchy" and not as easy, but, its ran fine for me (and im a pc pleb) from the start. Bumped it up to 6200 about a month ago, newer bios (pics of ram above) and its been fine. Killer even. (yerrr, boot times are a bit longer than what your use to, mine around around 32 seconds) and its from the memory. If i lower it to 5800, or the like, it boots in no time (18 seconds) but that doesnt bug me at all.  

Koyote7667
Level 9

What bios are you on now ? Post pic of bios screen. 

Koyote7667
Level 9

A older bios, isnt the answer, the newer, are actually better for memory, from what ive seen since october. ....The kit im using.

Image (3).jpeg

DanDanda69CZ
Level 9

Hi, I've been tinkering a lot with the new platform too and managed to get it sorted out.

Try setting it up in the bios
In boot menu - fast boot > disable
In AI overclock set EXPO profile
In the memory timing settings set: Power Down Enable > disable
And last, probably the most important point, set CPU core voltage manually to 1.2v at best, 1.25v at worst.

It should work then

ROG Strix X670E-E, Ryzen 7900, 2x16 Gb Dominator Platinum 6000Mhz

Thx a lot trying, i'm not an expert overclock guy, so i can not find how to change cpu volt on my rog strix x670e-e 

DanDanda69CZ
Level 9

hey, try this, I made a short video

https://www.youtube.com/watch?v=-N0-Xx8TjEk

ROG Strix X670E-E, Ryzen 7900, 2x16 Gb Dominator Platinum 6000Mhz

thank you very very much for the time you dedicate to me. I've tried all your settingd and suggestions, but it doesn't help, still can't boot if enabling expo, have to wait F1 prompt and go back to all in auto. i've ordered another cpu to test if the memory controller of my 7950x3d is defective. going mad here. 

say123
Level 9

your case is different from mine but do post here if the new CPU works out.

I should have it on Monday i'll let you know.

greggggggor
Level 7

I have the same problem. Tried two diffrent memory kits. As soon as a turn on EXPO the computer will not get past POST and I need to F1 in.