cancel
Showing results for 
Search instead for 
Did you mean: 

DDR5 AMD system 4800 MHz RAM issue

ruxima
Level 8

Hello, I have set up a DDR5 AMD system. However, I have an issue related to the RAM. The RAM modules are not functioning above 4800 MHz. I have tried Expo 1, Expo 2, and other profiles, but none of them worked. I also attempted manual overclocking, but it didn't yield any results. Thinking that there might be a problem with my motherboard, I sent it for service and had it replaced. I also changed the RAM modules and purchased ones that were listed as compatible with the motherboard. However, I am still facing the same issue. I am unable to enter the BIOS screen with any speed settings above 4800 MHz. The PC only works when the RAM is set to 4800 MHz. Could the issue be with the memory controller of the processor?  (I have tried all available BIOS versions for the motherboard).

Asus Rog Strix X670E-E

Ryzen 7900x3D

RAM: Ram GSKILL Trident Z Neo F5-6000J3238F16GX2-TZ5NR 2x16 32GB ( A2, B2)

MSI 360mm lıquıd cooler

1050w 80+ plat psu

 

2,579 Views
22 REPLIES 22

say123
Level 9

I don't know of it may work but try update the bios to the latest non beta firmware first?

Krukbee
Level 8

Same here, tried 3 differents ram, gskill, corsair dominator, corsair vengeance. I can only run at 4800. Sometimes they work with expo.  As soon i turn off the pc on next boot i have to clear bios, set on auto and use the 6000 ram at 4800 and higher timings. tried 1303, 1401 beta , 1410 beta

Sorry i can't help, but frustrated as you.

7950x3d 

Asus rog strix x670e-e

 

Koyote7667
Level 9

 

Running ddr5-6000 cl30 at 6200 here. 

X670e-e, EXP1,  Gskill (as you can see, it is a hynix kit)

 

Its been fantastic/great. No issues. 

6200.jpeg

Koyote7667
Level 9

6200-2.jpeg

Koyote7667
Level 9

(dont know how to edit posts)

Bios 1410, again Asus x670e-e, latest chipset drivers, latest everything. I was running the same kit around December at 6000. And it ran great then also. 

so what is your opinion, mb defective? New 7950x3d cpu has memory controller defective? 

 

What is my opinion on what being defective? I dont see anything being "defective". 

ruxima
Level 8
Need some ideas to solve this problem

Shenny
Level 11

From the various opinions I read in this forum, it might be also due to the memory controller in the CPU. You say that you have replaced the mobo and the RAM modules but it didn't help. The only thing that was not replaced is the CPU so it might be it or just a bad luck.

Some people report better results with BIOS versions as old as 0805, for example, but ASUS removed all older versions from their site and you don't have so many options which BIOS versions to use.