Showing results for 
Search instead for 
Did you mean: 

Curve optimizer settings not applied

Level 7

I have an x670e-F with a 7700x, running on the latest public UEFI (2007 right now).

I'm trying to fiddle with the CPU Curve Optimizer but I noticed that whatever the values I set, it looks like it's not applied at all.

I tried to put one core at +0 and all other cores at -30 in order to see a clear difference in the voltages and/or stability.

I'm supposed to see that one core at stock voltage and the others at a lower voltage, right?

But neither HWiNFO nor OCCT show any change, all cores still having the same voltage! Just like if CO was disabled...

I have PBO enabled with scalar set to 1 and offset to 0.

Do I need to enable a specific setting somewhere for CO to work?


Level 9

Maybe it doesn't want to work with such relatively extreme settings, where there is a 30 offset difference between the cores. Also, the voltage curve might be lower, but the core might now have the freedom to clock higher, resulting in same voltage but at higher frequency.  


Try setting CO to like -15 on all cores and comparing benchmark scores instead. 

I checked the frequencies under load (OCCT and CPU-Z), all core have the same.

I tried +0 and -15, no change, all cores still get same frequency and all same voltage...

Looks like CO does not work at all, could it be that latest AGESA or UEFI broke it?