Showing results for 
Search instead for 
Did you mean: 

Crosshair x670e Extreme - After update to BIOS 0922 can't use EXPO anymore

Level 10
I updated to 0922 to get ready for the x3d CPUs but now if I try to re-enable AMD Expo it will almost always POST into BIOS safe mode and ask to press F1 to setup or get stuck on memory testing. I reset BIOS to default and did the update like every other time I've done it on this board. I've been using this memory for months on all the other BIOS firmware updates without issues and haven't touched it, just updated the BIOS. Is this a known issue with a fix incoming?

EDIT: Turning on EXPO is the ONLY change from default BIOS.

EDIT 2: I tried setting Memory Context Restore to off, it got past POST once and then the issue came back, windows seemed perfectly stable when it got that far.

Level 8
Do all of the 7950x3D features work with BIOS 0805?

In April?

I mean, there will be no urgent updates, so the schedule will tell us when some issues might be solved.

Just got my 7950x3d + Crosshair Extreme + 2x32 G.Skill GB DDR5 6000

Not going to bother with any bios beyond 0805 for now , have Memory Context restore enabled + Expo II

Level 10
No luck so far, I've tested all the release/Beta/Test BIOS for my board since 0805 and only 0902 works, which is a beta the doesn't yet use AGESA

Level 7

I can't get my mobo to boot at all now. Black screen after initial bios load. Says press F1 to run setup. Nothing. Can't actually get into bios. How F'd am I?

Edit: I updated to the latest bios and it's the only one that would let me post. But now I can't enable EXPO 😞

Similar story with my setup. 7900x, all bioses after 0805 can't get expo to work. Same cpu and ram kits I tried work with msi and gigabyte boards...

Sticking with 0805 for now, just not sure if missing out on security or other features 

Level 9
Hey Everyone please help to make some noise and get this issue on ASUS radar for a proper fix!
You can open a case referencing this forum thread and one from reddit as well --
Easy way to do this is to go to ASUS Tech Support chat using this link --
Escalate this issue with their tech support agent and fingers crossed we get a fix soon without compromise!




I'd like to say that 64GB of memory for a gaming pc is overkill, except for maybe if you play flight simulator. And in most instances, 64GB can actually hurt gaming performance. But, the obvious thing to do here is to use a bios version that is stable for you.

I don't want to sound negative and stray anyone from 64GB but, you could avoid these potential problems with a 32GB kit, you'd even have slightly better gaming performance. 

 128GB (3000MHz) vs 64GB (3600MHz) vs 32GB (4000MHz) vs 16GB (4400MHz) | RAM Test in PC Gaming - Bing...

I was running 2x32 6000 C30 and found it to be terribly unstable as at that time I believe the bios version didn’t handle dual rank memory well at all. Since then I moved back to 2x16 6000 C30 and was able with bios version 1101 to get Expo 2 stable with a mild tuning on the CPU. That said, I am inclined to agree with you at this point as I don’t know or have not heard of anyone getting 2x32 stable with EXPO settings on Rev 1101 as of yet. 

Level 8

Hi everyone!
I was trying to make my PC post for an hour and a half, any changes that helped me previously didn't make any difference (can post at lower speed btw). As soon as I've turned "AI Overclock" to Auto and set regular timings (according to XMP) + 1,35 voltage (6000 kit) it posted with no issues. For some reason I don't expect them to occur in future, will keep you updated.
Bios version is 1004.

UPD it's the first time I'm able to run curve -30 on all cores. Nice mod help btw.