cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair x670e Extreme - After update to BIOS 0922 can't use EXPO anymore

decimus28
Level 10
I updated to 0922 to get ready for the x3d CPUs but now if I try to re-enable AMD Expo it will almost always POST into BIOS safe mode and ask to press F1 to setup or get stuck on memory testing. I reset BIOS to default and did the update like every other time I've done it on this board. I've been using this memory for months on all the other BIOS firmware updates without issues and haven't touched it, just updated the BIOS. Is this a known issue with a fix incoming?

EDIT: Turning on EXPO is the ONLY change from default BIOS.

EDIT 2: I tried setting Memory Context Restore to off, it got past POST once and then the issue came back, windows seemed perfectly stable when it got that far.
972 Views
56 REPLIES 56

Nate152
Moderator

Thank you Zimmyjee and ohyeah

To everyone in this thread - If EXPO isn't working for you, try setting your ram manually.
This usually gives better results and is easy to do.

AlexFranz
Level 7

Hey everybody!

I have a Crosshair X670E Hero + Corsair Vengeance RGB 32GB (2x16GB) 6000MHz in use. I decided to make a bios-update in the hope to improve the performance and maybe getting faster startup time.
But after I updated to the latest BIOS 1101 I can't get the system run in any of the 3 EXPO settings, just as described here before. I even tried to edit some settings manually but never with a satisfactory result because it was always worse than before.

After playing around and wasting a half day I went back to 0805. First start with EXPO setting and it's just running.

I hope this will we solved soon othwerwise this will become really annoying for people who bought those boards (especially in this price range).

Nate152
Moderator

Hello AlexFranz,

If bios 0805 is working well with EXPO, stick with that and keep an eye out for future bios updates.

Or, setting your ram manually can sometimes give better results, you could try this with Bios 1101.

 

 

AlexFranz
Level 7

Just a short info from me regarding to the latest bios on a X670E Hero + 7700x and EXPO:

BIOS 0805:
- EXPO I/EXPO II (6000Mhz 36,36,36,76 @ 1,35V VDD/VDDQ etc.) works right out of the box and I can start Windows normally with both of them
(I didn't changed anything than the EXPO | these are the values shown in BIOS: Core 1,36V / SOC 1,25V / VDDIO 1,34V / Misc 1,1V)

BIOS 1202 + 1302beta:
- With default settings (no changes done after the update) I can start windows normally (RAM runs at 4800Mhz 40,40,40,77 @ 1,1V)
- EXPO I/EXPO II (6000Mhz 36,36,36,76 @ 1,35V VDD/VDDQ etc.) > can't boot windows, the computer restarts and I got to the screen where I have to enter bios with F1 (ram speed is already reset to 4800Mhz as shown on this screen)
- EXPO Tweaked > I have to restart PC manually because qcode shows me all the time Od with orange light but nothing else happens

I went now for the 1302beta because of the actual lack of clarity regarding of possible damages of CPU/MB
(No EXPO, timings [46,45,45,87] and voltages all on default/auto | Core 1,36V / SOC 1,0V / VDDIO 1,1V / Misc 1,1 V)

I only changed the RAM-Speed to 5400Mhz - 5600Mhz didn't boot. If this run stable i'll try later to increase speed and timings with higher DRAM Voltage of 1,35V

Try bumping up these voltages.

1) Dram VDD voltage - 1.40v

2) Dram VDDQ voltage - 1.40v.

3) S.O.C. voltage - 1.20v

 

Teletha
Level 9

if you are on older bios than 1302beta and are using ram OC make sure the SoC doesnt go over 1.3.

my Neo 2stick cl30 64gb kit is working great with asus tweaked ram profile and SoC is around 1.236-1.242

On the 1302 beta bios with the extreme board with 7950x3d

AMD Ryzen 7950X3D [x2 360 Rad EKWB] | Asus Extreme x670E | RTX TUF 4090 OC@3GHz [EKWB Block] | Corsair HX1500i | G.Skill Neo CL30 6000MHz (2x32GB) | 980+950 Pro 1TB M.2 | x6 850 PRO 512GB | NAS 4x 18TB Seagate Exo Raid 10+Backblaze | Lian-Li o11D XL | Main Screen: Samsung NEO G9 | AUX: LG IPS7 27" (x2) LG CX 55" G-Sync | Copyright©1996-2023 Teletha™ All rights reserved. ® -"Lightning. It flashes bright, then fades away. It can't protect. It only destroys."