cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair x670e Extreme - After update to BIOS 0922 can't use EXPO anymore

decimus28
Level 10
I updated to 0922 to get ready for the x3d CPUs but now if I try to re-enable AMD Expo it will almost always POST into BIOS safe mode and ask to press F1 to setup or get stuck on memory testing. I reset BIOS to default and did the update like every other time I've done it on this board. I've been using this memory for months on all the other BIOS firmware updates without issues and haven't touched it, just updated the BIOS. Is this a known issue with a fix incoming?

EDIT: Turning on EXPO is the ONLY change from default BIOS.

EDIT 2: I tried setting Memory Context Restore to off, it got past POST once and then the issue came back, windows seemed perfectly stable when it got that far.
1,160 Views
56 REPLIES 56

frytom wrote:
Yes, I used 0805 with 7950X3D without any issue. Performance is slightly below 0922.

But I recommend the test bios 0088. It's stable like release bios 0805 but uses newer AGESA 1.0.0.5c (better performance with 3D-models) instead of older AGESA 1.0.0.3.

Best of all, test bios 0088 gives back the Memory Context Restore function, which did not work with 0922-0925. Enabling Memory Context Restore in 0922-0925 lead to really bad system malfunctions: CMOS-Reset, TPM vanishing, Windows destruction...

I use G.Skill DDR5-6000CL30 EXPO2-profile 64 GB. No problems with 0088.


Can you please share link of where I can download bios 0088? And just to confirm, with 0088 there is no performance drop compared to 0922?

ThanksÂ*

https://www.dropbox.com/s/cyp6psj2m95srvw/ROG-CROSSHAIR-X670E-EXTREME-ASUS-0088.zip?dl=0

It's from Shamino -> X670 resource page 38

For me 0088 is the first stable release after 0805. 0922 doesn't count for me, because it had lost functions... and malfunctions... so it was no stable release as advertised.

frytom wrote:
https://www.dropbox.com/s/cyp6psj2m95srvw/ROG-CROSSHAIR-X670E-EXTREME-ASUS-0088.zip?dl=0

It's from Shamino -> X670 ressource page 38

For me 0088 is the first stable release after 0805. 0922 doesn't count for me, because it had lost functions... and malfunctions... so it was no stable release as advertised.


this works same for x670E Hero?

Where did you get the 0088 download at if I may ask. Bios 1004 still doesn’t handle 2x32, 6000 in expo 1 or 2 and fails to post often on startup or even restart.

decimus28
Level 10
Unfortunately 0088 is still not booting correctly with EXPO for me with the g.skill 32x2 30-40-40-96 set.

Rock solid with 0805 though.

gderreck
Level 8
Greetings,

X670E Hero here. I attempted to update to 9022. Issues with Expo, never ending memory training. Finally, couldn't get out of the GPU 100% fan mode. Had to clear CMOS which got me back into setup. I was then able to downgrade to 0805. That version is stable. Expo 1 is active. Memory Context Restore is enabled. 6-7 second GPU fan then into POST. CPU is 7950X. Memory is G.Skill F5-6000J3238G32G.

I added the memory model in case anyone is looking for memory modules that should work with the Hero in Expo 1.

Cheers,
Graham

Maybe not the most helpful, but I registered just to post/ask questions after experiencing the same with my Strix X670E-E with the new 922 and 87/88 options. I couldn't get my old G.skill F5-5600J3636C16GX2-FX5 pair to work in Expo (after working mostly fine with 805). I always planned to upgrade to faster memory that hopefully behaved better, so I upgraded to a new Corsair Dominator Platinum CMT32GX5M2D6000 kit. Same exact results. Would always boot loop with failed to POST safemode, press F1 to change settings message. Memory Context didn't matter, EXPO 1/2 didn't matter. Wasn't working.

After someone on the Asus DIY PC group on Facebook said it didn't matter about keeping all HW the same, the rules changed in the UEFI, etc. I decided to upgrade my CPU to the 7950X3d since that's what I was upgrading BIOS for anyway. Imagine my surprise when 922 worked without a single hitch, EXPO on, 6000MT/s no issues in gaming or load testing.

Again, not the most helpful information, but it appears that sometimes what worked before, simply will not work due to some rule change in timing, etc. Perhaps my old 7950X didn't really want to play at those speeds, but my new CPU is fine with them? I have no idea. So far DDR5 (maybe just with AMD?) just isn't 100% yet in my opinion.

decimus28
Level 10
I am upgrading to a 7950x3d from a 7600x but I was waiting to get the RAM sorted out. So it is good to know the problem went away for you after the upgrade. I was thinking about going to that Corsair mem kit to at some point so also very helpful.

Rargo
Level 7
For some reason all the replies in this thread are blank to me. Just wanted to say on my X670E hero I have expo running with 4 sticks of dominator platinum. ‎CMT32GX5M2D6000Z36 running 6000mhz 64GB. Just put in 1 stick first, enable Expo and start up. Then shut down and installed the other 3 and its running solid. Sorry forgot details. 7950X and BIOS 0805

Just chiming in as someone with an x670e-hero. Reverting to the 0805 bios with a 7950x3d appeared to have solved a lot of the weird issues I was having with 0922. Ranging from not being able to turn on memory context restore without blue screens. To weird wake from sleep issues where the processor would get hotter while gaming then it normally would after a restart. My performance did appear to go down a bit on certain benchmarks, but stability is much better.