cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair e670x Extreme stuck on "Memory Test" no boot tried different RAM sticks

AquaRelliux
Level 8
I have been tearing my hair off trying to get this system to boot. I have tried 2 different RAM modules as listed below and I keep getting stuck on "MEMORY TESTING" on the motherboard debug display and the debug readout gets stuck on either "00" or "D7". I have tried 1 DIMM(A2), both channels A1,B1 and A2,B2 with both memory modules. I did find both kits on the QVL list for the motherboard. The BIOS was updated with the Flashback tool without a CPU present before I even tried to boot the system because that is needed to support the X3D CPUs.
I am slightly worried that I am not giving the system long enough to boot but I have given it around 1-2 minutes, and it is still stuck on the "Memory Test". I don’t want to run it to long since I only intended to test boot this system to start building my water-cooling loop. I don't have a spare air cooler on hand, so I booted the system with just the water block on as a passive heat soaker no water circulation. I have done this before on many systems without issues but maybe this will not work on the AM5 platform because it is notorious for long memory training cycles? Or is something dead? either CPU or Motherboard seems to be the culprit here.

System specs:

CPU: 7950X3D
Motherboard: Asus Crosshair x670e Extreme BIOS 0922
Memory tested:
F5-6000J3040F16GX2-TZ5RK 2x16GB CL 30-40-40-96 6000mhz
KF560C36BBEK2-32 2x16GB CL 36-38-38-80 6000mhz, tested in intel system known good
GPU: MSI RTX 4090 SuprimX, tested in intel system known good

I have seen many people with memory issues on the Asus motherboard this is the first time ever I have issues with an Asus motherboard. Maybe it is time to move on?
1,519 Views
1 REPLY 1

decimus28
Level 10
I had it stuck on memory testing on the ROG logo screen after a BIOS update during my 0922 troubleshooting. I cleared the CMOS with the rear CMOS clear button and when it turned back on it went to the "F1 for setup" prompt. In the BIOS I have to make sure EXPO is not enabled for it to boot in 0922.

EDIT : Also I haven't tried it but the support page for the board shows the new x3d being supported on BIOS 0705 and later. They wont have the new features of 0922 but I might try the x3d on the last stable BIOS (0805) when I get mine to see if it will run.