Showing results for 
Search instead for 
Did you mean: 

C5 POST error on all recent BIOS versions (X670E Hero)

Level 8

Hi all,

X670E Hero, 7950X (soon to be X3D if I can get one :D), 64GB Corsair Dominator Platinum 5600 kit

None of the BIOS versions released since 0805 are stable with both of my sticks of RAM installed. Even with EXPO turned off, I frequently can't POST, receiving a C5 error. The latest BIOS version (1003) is the worst of all - it won't POST at all with both sticks installed. I've tried all official versions since 0805:- 0922, 0925 and 1003 and all have issues with C5 errors. Even if I make it into the OS, I get regular blue screens.

Rolled back to 0805 for now and 100% stable again with EXPO II enabled.

Any ideas, please? Not a great experience tbh 😕




Level 9

Posted a reply to you via the other thread (I am curious about 0805 in my particular case).

The C5 error is likely down to the AGESA version. I've read a number of folks who won't go past, which is what is loaded in the 0805 BIOS.

UPDATE: the newly release BIOS version has seemingly solved all my problems. I'm back to EXPO II with no C5 errors and (so far) 100% stability in the OS. Will update if anything goes wrong.

Level 7

I just wanted to chime in that I had the C5 Qcode both on updating to BIOS versions 1410 and 1415. I have 2x32GB Corsair Vengeance RGB EXPO DDr5-6000 CL40. I waited a while on the C5 Qcode (at least 5 minutes or so) but nothing happened. I expect Qcode 15 for memory training. Unfortunately C5 is not mentioned in the list of Qcodes which to me is a major oversight by ASUS. After that while on C5 I gave the machine a cold boot. It then stopped a while on Qcode 70 which according to the qcode table is "PCH DXE initializatiobn started" but on my monitor it said it was doing the bios update. So there's some discrepancy as well in the Qcode explanations.

After that it jumped to normal oparation and I could enter the updated BIOS.

I must say the first time (updating to 1410) I had some other peripheral issues as well what caused me to take 1.5-2 hours before I got it working again. I nearly threw the machine out of the door at that time. This next time updating to 1415 was a lot smoother.