cancel
Showing results for 
Search instead for 
Did you mean: 

B650E-I no video signal from type-c port after 1818 BIOS update

Naughty
Level 7

Hello everyone!
Few days ago i updated my bios to 1818 from 1812 (display worked on this version). After the update completed i went to BIOS to change some options like setting EXPO, curve optimizer etc, but after pressing F10 black screen appeared saying "PD Firmware updating...". After the this firmware update completed to 100% system rebooted and i lost video signal frome the type-c displayport alt mode port that was connected to the portable 16 inch monitor by single cable. iGPU is enabled and working if i connect monitor to the hdmi port on the motherboard. Both type-c ports have power and work except for video signal. No other issues with the system.

So far i tried:

1. Changing settings in BIOS like setting igpu primary/enable hybrid graphics etc.

2. Rolled back to 1812 bios and then flashing 1818 again.

3. Reset CMOS

4. Hold the power button for a minute with the power cable plugged off.

5. Confirmed that the type-c port on the monitor itself works on a laptop.

6. Submitted a ticket to Asus support but they didn't suggest anything that i didnt already try...

My specs: B650E-I motherboard, Ryzen 7800x3d, A-Data 32Gb KIT AX5U6000C3016G-DCLABK, RTX 4060, ZEUSLAP-P16K 16 inch portable monitor.

Have anyone alse encouter this issue?

306 Views
0 REPLIES 0