Showing results for 
Search instead for 
Did you mean: 

B650E-F Gaming Wifi not booting and dead M2 slot

Level 7
  • B650E-F Gaming Wifi
  • AMD 7700X
  • FURY Beast 5600 C36 DC (2x16) in slots A2 and B2
  • Ryujin II 240 AIO
  • Rog RTX 4080 OC
  • FURY Renegade M.2 1TB
  • beQuiet 1200W straight power 11 platinum
  • Bios version 1616

I've had my build for about 6 months. Had some problems here and there, but bios and driver updates often solved them. Suddenly my computer bluescreens and reboots by itself a couple of times. I did not do anything about it as the machine worked fine afterwards. Then i unplugged the machine and went on holiday. It has been disconnected for over a month. Now when i got back it does not boot at all. It only goes into BIOS but does not start windows from the M.2 nor a new installation medium on a USB stick...

M2_3 (slot 3) seems to suddenly not be working at all. It cant find any drives mounted in this slot. If i move it to slot 1, it finds it, but cant boot. It does not seem to be a drive fault since it is not booting from a USB stick either. Other things i noticed is that the front USB ports does not work and i get the message "Please ensure to fully connect at least ONE 8-pin ATX_12V connector to the PSU for system stability. We strongly recommend connecting ALL ATX_12V connectors under heavy usage." during startup.

I have connected everything to the mobo and it has worked for months so i do not understand what happened... When i startup the asus splash screen, then black screen before it starts over again. I can enter bios and has set that to default settings.

Any tips is greatly appreciated.


Super Moderator

Hello, sounds as though there might be an issue with at least one of the ATX12 power connectors. Have you ensured it’s fully inserted or tried replacing it with another supplied with the PSU? It’s possible this is causing the system to exhibit the other issues you describe.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090