Showing results for 
Search instead for 
Did you mean: 

B650E-E Can't get back into BIOS

Level 7

New build with the ROG STRIX B650E-E and after completing the Windows 10 Pro install, I can't get back in to the BIOS.  When booting up, I've tried hitting the F2 key multiple times and even holding it down while booting up, but it always goes to the Windows login screen.  Also tried this process using the delete key, still can't get to the BIOS.  I then remembered the Windows power setting "Turn on fast startup" and turned that off.  Still, I can't get back into the BIOS when booting up from a powered-down system.

What am I missing?


Level 8

I have the same issue with Strix X670E-E, every other problem, appears to be solved now.The only way to enter BIOS is clearing CMOS and let the motherboard to force the BIOS initial setup. I moved up to last beta BIOS, 1003, but this one marked my 3080 ti incompatible un turned it unusable, so I went back to 0925 and now the 3080 ti works fine. But, the most important issue the upgrade-downgrade solved was the high time booting my PC (about 3 minutes) because of DDR5 Memory checkings. Now it boots up in 40 seconds.

Just for context, this is my hardware: ROG Strix X670E-E, Ryzen 7950X3D and 64Gb of this G.Skill RAM F5-6000J3038F16GX2-TZ5NR, MSI RTX 3080 Ti VENTUS 3X OC. All the M.2 fulled. The main one with the operating system on Samsung 990 PRO, another Samsung 980 PRO, another 970 EVO PLUS and one WD 850X.

Thanks @mdelacruzperu, but I put a lot of effort into setting up the BIOS the way I wanted and resetting it would only be a last resort.

BTW, we have almost the exact same setup, especially with the M.2s and G.Skill memory!

I understand. I only change Memory Speed and PBO Curve Optimizer. But continuing with testing I had discovered that I can't overclock my memories to 6000 Mhz using Expo I or II because, despite the fact that memory works fine and stable once Windows boot up, here is when the DDR5 testing takes aroung 1 minute and a half to complete. I incremented the time of the splash screen from 3 seconds to 5 seconds and nothing changes. I can see the option to press F2 or Del to enter BIOS but it disappears so fast that I don't have time to press the key.

Level 9

Do you have two GPUs? If so, make sure you are cabled to the first card.

If not, boot into BIOS from the Windows Recovery menu and then make sure the BIOS Splash Screen is enabled in the settings (it may be disabled, which is why you are never given opportunity to get in)

@ApothocaryThanks for the tip, but I only have 1 GPU.

Almost embarrassed to admit that I have no idea how to "boot into BIOS from the Windows Recovery menu".  Where would I find this?  Don't remember ever having to do that before.

No trouble! Was going to type it out, but this is probably more helpful: 

@ApothocaryThat article did look promising, but I tried it and still didn't get into the BIOS.  The article did bring up a good point, that with modern fast systems, we don't get enough time to hit the F2 key.  I also just realized that I never see the BIOS splash screen at all.  Strangest thing is that the first few times I booted up, I saw the ROG splash screen.

So frustrating!😫

Okay, if you both have a 3080, I think I may have found the issue. NVIDIA have released a statement. It's to do with the GPU driver not initiating the correct DisplayID/driver until Windows boots. See here for all the info/fix: 

Let me know if it works.


I applied the update and got this, I restart the PC and the problem is stille there...