cancel
Showing results for 
Search instead for 
Did you mean: 

Asus TUF X670E plus memory issues

Ciprianus
Level 8

Hello fellow Asus colleagues. 

I encountered a strange problem with my recently bought Asus Tuf x670e plus paired with a 7700x3D. 

I have two trident z 2x16 gb 6000mHz modules, but the system won't boot but with just one module. In bios the module is locked at 4800 mHz. I succsesfully boot to windows, turn off the PC, install the other module, but the orange led in front of DRAM is on and the sistem stays black. 

Did anyone encountered this problem ? Thank you in advance!  

1,204 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Hello,

As suggested update to latest UEFI.

If the system still refuses to POST remove the CPU and inspect the CPU pin pad, then remount the CPU and cooler whilst ensuring for consistent mounting pressure. DIMM slot issues are often related to CPU pin pad contact.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

View solution in original post

7 REPLIES 7

Darox
Level 9

 M trainin times you have to give 5 minutes bootup  and try other single M to test is working like other one so I did same problem after couple try it did boot perfectly  . This is Attitude of AMD 5 platform has to with Memory compliance .

So i did try to switch the modules. With only one it boots without any problem. I get into Windows, no errors. When i put both in place, the monitor is black and there is the orange light of DRAM on. I don't really get what i do wrong ...
LE:

i think i actually found the problem. The RAM i ordered F5-6000J3238F16GX2-TZ5NR is not found on the support list on the official website. The only 6000 MHz RAM GSkill modules compatible with this board are F5-6000J3636F16GX2-TZ5NR, F5-6000J3038F16GX2-TZ5NR, F5-6000J3636F16GX2-FX5. 

i think this may be the problem. i will try to order another set of RAM modules and i will make an update on this post if the problem is solved. 

Ciprianus
Level 8

Update:

Still didn't solved the problem. Ordered  compatibile DDR5 modules from the motherboard list, the system still refuses to boot with two sticks of RAM, same DIMM orange LED on, same BSOD 🙄

Well seems like me I have new parts 7950X3D, X670E-plus and KF556C36BBEK2-64 what are by Asus and Kingston approved in list of compatible. When i set any profile EXPO orange led, when all keep AUTO 4800 only PC work.  

I would assume you have the latest BIOS and if not install that . Also get a memtest Flash Drive made up and  test your memory with that.  Make sure they are fully inserted, with the Hero it happened to me that one wasnt fully inserted. Maybe get some 5600 ram  and if that dont work do a RMA

 

Hello,

As suggested update to latest UEFI.

If the system still refuses to POST remove the CPU and inspect the CPU pin pad, then remount the CPU and cooler whilst ensuring for consistent mounting pressure. DIMM slot issues are often related to CPU pin pad contact.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Happy new year everyone. That was the problem.  Buying the motherboard as "resealed" caused me this issue. I remember pretty well that i did not bend that pin, it was impossible. Sent the motherboard back, bought a simiar one, not a single issue with  it. It worked even with the first RAM modules that were not compatible with the motherboard.

Now i have another stupid issue, aparently i get random blue screen recovery from windows. sometimes it boots, sometimes it's blue screen.

Also the POST is a little longer than my previous sistem. around 15 seconds. idk if this is normal