cancel
Showing results for 
Search instead for 
Did you mean: 

Asus TUF Gaming B650 Plus Wifi not giving Display after BIOS flashing

nicefellow1234
Level 7

Hi Everyone,

 

A few months back when I created my PC with Ryzen 7900X & XPG DDR5 6000 Mhz CL40 32 GB Kit with Kit number (AX5U6000C4016G-DCCARGY) and the boot times were very slow on it. I tried all of the possible solutions but nothing worked and I accepted that I will live with these worse reboot times like would take almost a minute or more than that sometime. Sometime would even fail to boot up and then I would have to power it off from the power button and then powering it on would fix it.

 

Just today I just thought that I would update the Bios, may be the slow boot times issue would be fixed so I went ahead and download the latest BIOS version 1654 so when I copied it over to the USB and I went into the Asus EZ Flash 3 and I selected the cap file from the USB and when I clicked on it so I got a popup saying that you want to read the file and I clicked yes and then the monitor screen went black and I waited and thought may be the flash is happening but then after a while nothing was happening so I forced power down the PC and then I powered it on again so after that the PC never gave display while waiting each time for a few minutes.

I do not have a buzzer so I don't know if it's giving any error beeps or not. Next I went ahead and shorted the CLRTC two pins for a few times during multiple times for more than 10 seconds. One time I even removed the CMOS Battery as well and then installed it back again after a few minutes but no display at all.

 

Last thing which I tried was flash the bios through the BIOS flashback functionality by copying the bios cap file renamed by BIOSRenamer. I disconnected all of the input wires and just left the display wire and did not turn on the PC through the power button and inserted the flash drive in the BIOS labeled USB port with the bios version 1654 cap file in there and clicked bios flashback button for more than 3 seconds and it started flashing. But it would turn to solid light and I knew something was wrong with it. Later I realized that the USB had GPT drive so I turned that to MBR & also formatted it Fat32 and then the light kept flashing for a few minutes and then stopped blinking so I knew that the flashing completed successfully but when I tried powering on the PC so again no display.

Last I flashed an older version bios 1409 as well but still the same thing no display now I am wondering that what seems to be the issue in there.

One thing which I noticed was that now when I left the PC turned on for a while so it never gives the display neither does the input devices lights up which is also a sign of not posting because the input devices lights up when the monitor starts giving Display and also after a while it just shuts off now. That's really very strange. Is it supposed to do that? Shut off when the PC does not post after a while?

Also I removed the rams & then plugged in and also tried with just one stick as well in different slots all around with each stick each time individually and collectively but nothing worked.

I am quite frustrated at this moment and don't know what to do with it. I am from Pakistan so I can't send it to any customer support service here as well because we don't have them here.

Can you guys help me out with it?

Thanks

IMG_20231010_053254.jpg

IMG_20231010_053230.jpg

IMG_20231010_030004.jpg

IMG_20231010_053221.jpg

2,245 Views
1 REPLY 1

Nate152
Moderator

Hello nicefellow1234

It looks like you have your memory installed in the A1 slot.

The recommended configuration is slots A2-B2 (2nd and 4th slots from the cpu).

Turn off your pc and turn off the power supply switch.

Install one stick of memory in the A2 slot, 2nd slot from the cpu.

Take out the cmos battery for 10 minutes, press and hold the power button on your case for a few seconds to drain any left over power.

After 10 minutes, install the cmos battery and try booting up.