cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Strix X670E-F, BIOS flash ended in disaster

GrimReaper85
Level 7

Hi,

Today I wanted to update BIOS to latest 1709 as I had trouble with stability at DDR5-6000 and was only stable on 5600.

I went into BIOS, loaded system defaults and started EZFlash from BIOS. After about 5s I already knew something really bad happened as PC just restarted itself.

Then it was on a black screen loop, fans spinning and turning down, and I left it like that for 6-10 min at a time. There is also constant orange DRAM LED lit up.

My RAM is G.Skill F5-6000J3038F16GX2-TZ5NR. And CPU 7600X.

I then tried only left stick in 2nd slot and then right stick in 2nd slot. Same DRAM LED. RAM worked fine before so I would rule that out, both 2 sticks can't just go bad during BIOS flash.

Then I tried to flash it at the back BIOS USB port with BIOS Flashback, at least 5 times with 1303 which I had before and 1709 BIOS.

So I guess the motherboard is bricked. My biggest question is, how could this happen? BIOS flashing sure is not the safest thing to do with PC, but sometimes it is necessary and there should be a way back which in theory is BIOS Flashback, but in reality it doesn't help at all.

4,307 Views
19 REPLIES 19

Nate152
Moderator

Ok, thank you for trying.

I don't think there is much more I can do to help you, so I'll have you contact ASUS Technical Support and see what they suggest.

I see you're from Slovenia, I found two phone numbers for you.

+386 (0)59 343 400

+386 (0)59 045 400

Mon-Fri 09:00 - 17:00

Let me know how you make out with this.

 

 

 

 

TOday the same happened to me and my X670E-E mothermoard. Did you have any luck with this?

GrimReaper85
Level 7

I haven't. I simply bought a new motherboard and will RMA this one.

For next time, I think flashing from the back USB port labeled "BIOS" (BIOS Flashback) is way safer than flashing from the BIOS. As everything works with shutdown computer, so bad RAM or something else shouldn't be a problem.

I actually believe bad RAM stability killed my motherboard. Although I already got it stable at 5600 1 day prior to flashback and I did use BIOS defaults which should give me 4800. But still this is the best explanation I have for now. Because RAM was the cause for instability already when I had it at 6000. That's why I wanted to update the BIOS in the first place.

I also remember seeing BSOD at stock speeds during my DDR4 overclocking era (I think 2133 for DDR4), so stock doesn't necessarily mean everything will be completely stable.

If you reset the bios to default prior to flashing, you would have been at 4800 which is stable for any ram and cpu.

TheAmazingHobbi
Level 7

I think I'm having the same issue - Just got the system new a few weeks ago and had a few blue screens every now and then, however yesterday the pc was stuck in the post bios screen so i shut it down and tried turning it on again - After that I got blue screens every few minutes (sometimes even after logging into windows and doing nothing) so I figured it couldn't hurt to update the bios. Followed the bios flash instructions exactly and now nothing I do seems to have an effect. I was on bios 0805 originally (out of the box) and tried upgrading to 1602. 

Mainboard: ROG STRIX X670E-F GAMING WIFI

RAM: G.SKILL F5-6400J3239F48GX2-TZ5RS      (Yes it's on the QVL even with 6400mhz)

CPU: Ryzen 7950X

 

Can't RMA the board since the return window ended a day prior to the troubles. Is there anything I could do?

GustavoLeite
Level 7

I had just tried the first bios that can be found on Asus site (1003), and still nothing. My Q Code begins at 15 and orange light, and the light goes to red, and finally Q code goes to A0 and stands still. Any other ideias besides a new motherboard?

GrimReaper85
Level 7

Update, I got a call from repair service today and the CPU 7600X is dead.

I bought ASRock X670E Pro RS board before sending ASUS one to service. Only difference on ASRock was the red CPU and DRAM light, on ASUS it was just orange DRAM light.

CPU was on 1.395V SoC/VDDIO (read from HWiNFO) since beginning of October 2022 until end of april 2023, these are default ASUS voltages at least until BIOS 1303 from 27.4.2023. Then when I read about X3D CPUs dying I tested lowest stable voltages and got to 1.30/1.25V, maybe 1.27/1.22V could also work, but 1.25/1.20V wasn't stable.

So, the problem is the cpu only, not the motherboard? But how can  a bios update damage the CPU? If you only had changed the cpu on this board, would it work?

Nate152
Moderator

Hello GustavoLeite

For AMD motherboards, code A0 is referring to your boot device.

boot up device abnormal.png

Hello, thanks for the reply, but unfortunately it isn't the boot drive. I had tried to boot with and without, but it always stop with A0 code, red CPU light and no video on dedicated or integrated graphics. I also tested the boot drive on other computer, and it is working fine...