Showing results for 
Search instead for 
Did you mean: 

Asus Proart X670E-Creator Wifi. Expo settings does not work with 4 DDR5 slots (4x32gb)

Level 8

I can't get work my all 4x DDR5 memory slots with EXPO setting. I have 4 x 32 gb (G.Skill Trident Z5 Neo, DDR5-6000, CL30-40-40-96, 1,40v). I can start my computer with 2 x 32 gb with EXPO on, but when I add rest off my memory, computer won't start. Motherboard has orange light on. When I have all my 128 gb memory installed I have to turn EXPO off and only then my computer starts. I have tried switch memory places but without luck.

What I am missing? Is it even possible to run with EXPO if I have all memory slots filled with DDR5 memory?

I have updated BIOS to 1303.

My pc specs:

  • AMD Ryzen 7950X3D
  • Asus Proart X670E-Creator Wifi
  • DDR5 128gb (4 x 32, G.Skill Trident Z5 Neo, DDR5-6000, CL30-40-40-96, 1,40v)
  • Seasonic Vertex GX-1200
  • Gigabyte Geforce RTX 4090 Gaming OC
  • Samsung 990 Pro PCIe 4.0 SSD
  • Windows 11 pro

Level 14

Your memory is not on the ProArt X670E-Creator Wifi Memory QVL for a 4 DIMM config.  The "socket support" column tells you whether each part is supported as a 1, 2, or 4 DIMM config; so you need "1,2,4" for 4 DIMM configs.  I can't tell if it's on the QVL for 2 DIMM configs or not, as you didn't give the part number.

4 DIMM DDR5 configs are more troublesome than 2 DIMM configs.  4x32 configs are particularly difficult to run with overclocking (EXPO is overclocking).  The only 4x32 config listed for your board is a Kingston 4800 CL40 part.

It's possible you might be able to manually overclock it a little to somewhere between the default JEDEC speed and the EXPO speed, but it's unlikely to work at EXPO speed in a 4x32 config at the moment (possibly future BIOS & AGESA updates may improve memory compatibility, but nobody really knows for sure).

Thanks Murph for good answers! I didn't realize to check memory compatibility for this motherboard. I just though this motherboard supports all kind of DD5 kits up to 128 Gt. Well...lesson learned. I hope Asus will support more DDR5 configs with future BIOS updates. Until then I guess I may try your suggestions.

Part number for DDR5 memories are  F5-6000J3040G32GX2-TZ5N

Yeah. Thank you Say123. I didn´t realize to check this list before buying computer parts. I hope future BIOS updates adds more support for different DDR5 configs.

Hey Tony,

I can tell you I recently went through this, I had not done 100% of my research prior. Now,

your CPU the 7950X3d (same as me) Cannot handle 4 sticks of ram at 6000mhz first off. so if you go with a 4-stick config, the CPU won't run it higher than 3600. You may be able to OC, but no guarantee you'll hit the speeds you want when you're already reduced to 3600. Now if you stick to 2 sticks you can run the 5200 and pretty easily hit 6000+ changing manual settings.  So the short is, you have ddr5 6000 ram and want to run 4 sticks, you will likely NOT get near 6000 on your speed because the CPU lists it runs 4 sticks at 3600.  

This is my tale to get there and what I'm currently using.. I too wanted 4 and ended up with 2 48gb modules to get as close to max ram as I could. 


I first ordered the 192 GB Corsair Vengeance DDR5 5200 kit CMH192GX5M4B5200C38 , before i realized it couldn't go over 128gb with the CPU. That said, this kit (2 sticks) worked in slots A2/B2 (those are the priority ones it shows in the book) But i could not get it to stable OC up to 6000. 

So i got an RMA, and went ahead and ordered  2x kits of 64GB (32/stick) of Corsair Vengeance  6400.. and while i was waiting on delivery I noticed where Ryzen says it cannot run 4 sticks above 3600. So I canceled this and ended up ordering

 G. Skill Trident z5 - F5-6400J3239F48GX2-TZ5RK DDR 5-6400 48GBx2 Kit with CL 32-39-39-102  

This would not work right away, so I put 2 sticks of the first ram back in, booted up, and checked on the Asus website. They had beta Bios out for compatibility with 24/48gb sticks. Which was strange because it worked fine with the corsair 48gb sticks. But, I updated the Bios shut it down, and plugged in and bam, worked like a charm. 

Version 1410
Beta Version
9.75 MB

"1. Update AGESA version to Combo AM5 PI
2. Support 48/24GB high-density DDR5 memory module.
3. SoC voltage for Ryzen 7000 series limited to a maximum of 1.30V to protect the CPU and motherboard.

This ram is running at the CPU max 5200 right now, I can get it to OC to 6000+ and its mostly stabile until a reboot. Then it does not want to POST and I have to clear CMOS and start again.  So, for now. I'm running them at the stock 5200, its working great, no issues with stability. I did a 10 minute stress test and no crashes or anything. Has handled all of my large format hi-res 3d scan processing etc with 0 issues and fast as lightning. 

Hope this helps



Hello, something is changed? Or you use 5200 and don’t try make it 6000?

Yes it is!  I have the same memory and the same problem.  Looked it up on the QVL before I bought it!  I'm not stupid, either.  I suspected a problem with the lowering of the SOC voltage limiter in the 1602 BIOS update, but the problem seems to predate it, according to this poster. Also thanks for explaining the "1,2,4 socket" column, something ASUS totally failed to do. I know there is a language problem, but Canada has literally hundreds of thousands of university educated Cantonese, Mandarin, English and French second and later generation speakers who would be glad to contract translation services for ASUS support.