Showing results for 
Search instead for 
Did you mean: 

x570 Reverb G2 usb 3 issues

Level 7
Does anyone know if Asus is actually aware of the issues with the reverb G2 on x570 motherboards?
Plugging into the back of the motherboard always to ends up in the headset not reacting or throwing errors. My front usb seems to work, but not very good, lots of loss of tracking.
At first when looking around this seemed to be a x570 specific issue, but people on AsRock motherboards report no issues at all, people with gigabyte MB report that all is fixed with a bios update.

I had to resort to buying a usb3 add in card just to be able to use the g2.
Is Asus aware of these issues, are you working on this ?
Are there any people here with an x570 and a reverb G2 where it just all works flawlessly?

Level 7
I just ordered the G2 headset and then saw all these problems with x570 motherboards. I have Asus Strix x570-E. Should I be cancelling the order or is there a way to make it work?


I was running into USB detection issues with an error code 7-14 on my Crosshair VIII Hero on initial setup.

The only USB ports that seem to allow the headset to go through the Windows Mixed Reality setup were the rear USB 3.2 Gen 1 ports E1-E4. Refer to motherboard manual to see which rear ports are categorized as USB 3.2 Gen 1.

Also on my headset, connecting the DisplayPort to the headset takes some force to plug into the headset. You can feel when its fully inserted. I am running all latest chipset and graphics drivers and did not have to set any BIOS options related to USB or setting PCI-E Gen.

you can make it work, could be that you need to resort to a usb hub or pcie expansion card.

My 3.2 gen 1 usb ports on the mb don't work either

Crosshair Dark Hero here. None of the slots on the back worked with the G2. It did work through a USB hub but that caused a wiring nightmare so I bought a pcie usb card instead, and that seems to be working fine.

I really wonder what's the cause here, it's like nobody wants to explain what goes wrong.
Some brands don't have it some have solved it. I wonder what Asus has to say about the issue.

Guys, AMD are looking for users with USB problems. See here:

Thanks for the heads up. Let's hope this can finally be resolved

I had issues at the start with getting my C8H to recognise the Reverb G2. Eventually, I found a port that worked, and it is the blue chipset USB-A port on the back panel. It was the top row, right most blue USB port when you are looking at it from the back on the tower case. So you need to use the included USB-C to USB-A adapter. I also tried the front ports through the motherboard's internal headers, not none of them worked.

After it detected and I was able to use the G2, I started getting minor USB disconnects in gaming situations where I had loud audio together with the graphics through the G2's display. It manifests as what I could describe as the headset doing an eye-roll. Sometimes it disconnects out of WMR and sometimes it recovers. This issue did not appear if I was just using WMR and moving around the house and watching VR videos.

I then changed all my PCIe slots to gen3, which has seemed to stop these disconnections during gaming. So now I am able to run the G2 for long durations without issues.

mr_Loma wrote:
Thanks for the heads up. Let's hope this can finally be resolved

As stated by many users on various online forums, the AGESA update seems to be useful in solving various usb stability problems, but it is useless with the G2.
In fact this viewer has problems even with intel configurations, from what I have read around. In general it is very unstable and it sometimes seems even necessary to have the power cord replaced.
I built the new pc just to be able to take advantage of the VR with the conviction of buying the Reverb G2, but after all I've read I'm seriously thinking about buying a Quest2 instead (a little less resolution but MANY fewer problems).