Showing results for 
Search instead for 
Did you mean: 

X570 ProArt Creator - No GPU Output When Using Riser Cable In PCIEX16_1

Level 7

Hi All,

Hope someone can advise further in relation to this issue I'm experiencing.

I'm using an X570 ProArt Creator Wifi, Ryzen 5900X, Asus TUF 4090 & 32GB DDR4.

I have two NVMe installed, one in M.2_1 (1TB) & the other in M.2_3 (4TB).

Installed the 4090 in to PCIEX16_1 and it works flawlessly, PCI Gen4 x16.

Due to the size of the card and the case I'm using, I decided to vertically mount it, so I bought a Lian-Li  kit for my case (Lian-Li 011D), which came with a PCI Gen4 riser cable (x16).  Installed the cable, turned on the PC and no GPU output.  Tried lots of things, like changing the PCIe version for PCIEX16_1 from the default of "auto" to "gen4", even "gen3" and still no video output.  Tried the same setup with a 3080ti and the same issue, no video output.

By chance, I thought I would try the second PCIe slot (PCIEX16_2) and this time I got video output, but when I got into Windows, I could see the PCIe version was only Gen4 8x, which is expected when looking at the spec for that slot.  The question is why the first slot isn't working with the riser cable at all, but works fine when the GPU is installed directly in the slot ?

This is the kit I ordered and installed -

If anyone has any ideas on what I could try to get the card working in the first slot when using a riser cable, which I would expect to work and work at Gen4 x16 speed.

Thanks !