Showing results for 
Search instead for 
Did you mean: 

Windows system sound not working after OS update and official Realtek driver install

Level 7
Hello Everyone,
I reinstalled OS and then install Realtek audio driver from Armoury crate. Unfortunately, any of the system sounds aren't working with my speakers, only sounds from the media player, browser, and calling apps (skype/slack) are working but no notification sound, no incoming ringtone. If I uninstall and delete the Realtek driver from the device manager, then it works. I also tried manually installing the Realtek driver (, but unfortunately, it has the same issue. It was perfect before reinstallation, maybe new update creates this issue (I'm not sure). If I connect my headset, then windows sound works perfectly. My headset doesn't use the Realtek driver.


For the manual installation, If I run "AsusSetup.exe" then It doesn't play any sound like the above description. But If I uninstall Realtek driver > run "Setup.exe" > Reboot and then windows sound back to work but it redirects my external microphone to the speaker, so infinity echo comes from my speaker with my voice. I also check if microphone properties to see if "listen to this device" is on or off but it's off there.

I also delete Realtek audio driver > remove Realtek audio console > Reboot > check windows update > check driver update > install Realtek audio console from Store but it's not opening.

I reboot to safe mode > uninstalled Realtek audio driver, Sonic Studio3, Sonic Radar 3, and DTS using Revo Uninstaller pro. Then uninstalled Realtek Audio, Sonic Studio Virtual Mixer from device manager > Uninstall all audio drivers, GPU driver using DDU and then rebooted to normal mode. Install AMD display driver, official audio driver, and reboot but same result!!!!!!

In this case, what should I do now?????