Showing results for 
Search instead for 
Did you mean: 

USB Type C port always negotiates to USB 2.0 speeds

Level 7
Hello everybody,

I delayed this question since I wanted to eliminate all variables, but now I did and I still haven't figured it out.

My Crosshair VII Hero always negotiates my phone connection to USB 2.0 speeds. Here are the variables:

- Type C Cable - Ringke branded, USB 3.1 5Gbps capable and USB-PD compatible. I don't think it's USB IF certified, but it works fine on my Dell Latitude work laptop with both phones mentioned below.
- Phone - tried a Pixel 2 XL and a Sony Xperia XZ3. Both USB 3.1 5Gbps capable and USB-PD compatible. The Pixel displays a "charging rapidly" prompt when I connect it, but both of them work at USB 2.0 speed.
- OS - Windows 10, 1803. Reinstalled it yesterday and for the first time ever, it connected to my XZ3 as USB 3.0. When I tried to copy some files, it disconnected after 2-3 seconds. After un-plugging and re-plugging, it negotiated its speed to USB 3.0 speed and disconnected during file transfer . Now it only connects at USB 2.0 speeds, just as before the reinstall.

Have you guys tried the Type C plug on you motherboards? What was you experience? I was pretty excited to finally have a port through which I could charge my phone and transfer my music quickly, but now I'm pretty bummed out.

Have you tried installing drivers from ASUS's website rather than going with Windows default? There could be a newer chipset driver available.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

All drivers have automatically been updated through Asus Grid. I just tried downloading the chipset drivers from the website, but they seem to be the same.

Ah bummer. I'd probably still try another cable if you can just in case there is some difference that makes the ASUS machine more sensitive than the Dell. I realize the cables aren't cheap or widely available but it's worth trying before RMA'ing the laptop.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Sorry to post in this old topic, but I have the same issue.

Tried to connect an external SSD with UASP support and USB 3.1 Gen2 connection to the Type C port on my x570 Motherboard, but it negotiate as USB 2.0 connection and speed (480mbps)

Tried connecting the same disk and same cable on the Type C port from an USB 3.1 Gen 2 PCI adapter installed on the motherboard, and it works fine, negotiating USB 3.1 Gen 2 connection and speed (10Gb/s)

Did someone had same issue?

@Geo2160 did you solved the issue? How? thanks

Motherboard is an Asus ROG Strix X570-E Gaming, all drivers and AMD chipset driver are the last released from ASUS.

I am having a similar issue none of my transfer speeds on my USB ports are working fast at all. Like 20 to 40 megabytes per second