cancel
Showing results for 
Search instead for 
Did you mean: 

USB-C AUDIO on the ASUS ROG Strix B550-i Gaming

Sihastru
Level 7
Hello!

The USB-C AUDIO port on my ASUS ROG Strix B550-i Gaming seems to not work anymore after I updated the BIOS to 1803. It worked mostly fine with 1801 and lower, with the included adapter USB-C to 4 pole audio jack, I was using it to connect my headphones + mic without needing to disconnect my speakers. I say mostly because the jack sensing thing was finicky on the USB-C, and sometimes required a reboot.

Can anyone with this motherboard confirm that they still have audio through the dedicated USB-C AUDIO port on this version of the BIOS? Eventually I will downgrade the BIOS to 1801 or even lower (160x, I have all of them, even if ASUS pulled all but 1401) to diagnose this issue, but for now I would like to avoid it.

Of course I already tried a fresh OS install (NVMe SSD upgrade), with fresh drivers (the ones on the download page and the update available through Armory Crate), and even the experimental Realtek audio drivers available in the ASUS forums (UAD - ASUS ROG SS3-DTS MB). None seem to work.

Full system specs in the profile section on the left.

Thanks!
There are more things in heaven and earth then are dreamt of in your philosophy.
1,110 Views
17 REPLIES 17

Hi
I upgrade BIOS version 2007 and find a interesting solution.

Before upgradeing to 2707, my APM configuration settings are: ErP ready:enable; Energy Star ready: enable; CEC ready:enable, and have to switch off power supply to have usb-c audio works.

I change ErP ready setting to disable and others remind the same. Then try the procedures to have the usb-c audio works, and find that the usb-c audio function works fine even I restart/ turn off my computer as normal.

Try it. I wish this solution also works for you .

Any updates on this guys? I just bought a brand new strix b550i and updated to the latest stable BIOS. I cant find the USBC audio in my audio settings. Nothing shows up.

avengerdot0_ wrote:
Any updates on this guys? I just bought a brand new strix b550i and updated to the latest stable BIOS. I cant find the USBC audio in my audio settings. Nothing shows up.


Hi, I upgrade my BIOS to version:2201 and use the audio driver from https://rog.asus.com/forum/showthread.php?117596-DRIVERS-Realtek-Audio-(MB-Intel-2xx-3xx-4xx-5xx-amp...

The type-c audio output works fine.
Make sure you follow the uninstall steps then install the new audio driver.

Good luck

Hi,

I am having a similar problem with the USB C adapter. I can hear the sound but cannot use my mic with the headphones.

Additionally, if I pair headphones with Bluetooth, sometimes I cannot hear any game sound but teammates can hear me. Does anyone have a similar problem?

Sihastru
Level 7
Well, disappointingly, it only worked for a couple of days. I'm back at square one, the problem is back and it persists.

I have MoKiChU's drivers from this thread. There's a new version now, I still have 6.0.9102.1. For my motherboard I used the "ROG SS3-DTS" version. Make sure you follow the procedure described in the thread, maybe you'll have better luck.

I've pretty much given up on this. Perhaps the upcoming AGESA 1.2.0.2 will fix this problem sometime next month. If it won't then I'll try to open a ticket afterwards, but I've never had a good experience with support.
There are more things in heaven and earth then are dreamt of in your philosophy.

Sihastru
Level 7
Updating to BIOS version 2007 (beta) did NOT fix this issue.
There are more things in heaven and earth then are dreamt of in your philosophy.

Sihastru wrote:
Updating to BIOS version 2007 (beta) did NOT fix this issue.


same above

even I updated the beta bios of 1.2.0.1 Patch A
the Audio type-C and one of the USB-A still disconnect sometime
I turned off the Global C State, didn't change anything

ar_0
Level 7

I'm having the same problem