Showing results for 
Search instead for 
Did you mean: 

TUF GAMING X570-PLUS - yellow led on cold boot

Level 7

Hi, I have problem with booting my pc. Every day it stucks on first boot, led on motherboard lights up solid yellow. Nothing happens no matter how long I would wait. When I power off pc by holding power button for few second and then turn it on again, it boots without any errors. Someone had similar problem? Its really annoying.

  • CPU: Ryzen 5 3600
  • MB: ASUS TUF GAMING X570-PLUS, newest BIOS version 4602
  • RAM: 32 GB - 4 sticks (2 kits x 2x8GB) HyperX Predator HX432C16PB3K2/16, Enabled DOCP profile 3200MHz
  • Power supply: Seasonic 650W Focus Plus (SSR-650FX)




Level 7

I had similar problem. Tried many things like running at stock speed, nothing worked.

When I disabled docp, set it to auto and set the ddr speed to 3600.

BIOS picked up relaxed ram timing than DOCP profile. 
And the problem went away; weird…

I have rizen 7 3700x, 4 sticks of 16gb gskill, same mobo and firmware.


Level 14

Is it DRAM_LED that you're seeing, near the top of the right edge of the board (see page 1-8 (PDF page 22) of the TUF GAMING X570-PLUS User’s Manual)?  It could be the XMP/DOCP overclock profile on the RAM is just a little too aggressive.  You can use the SPD tab of CPU-Z or HWiNFO to look at both the default JEDEC timings of your chips and the XMP/DOCP timings.

According to the Memory QVL for 3rd Gen AMD Ryzen™ Processors X570, your HX432C16PB3K2/16 should be using 16-18-18-36 in its XMP/DOCP overclock timings.  The HX432C16PB3K2/16 data sheet says that part has two XMP profiles on it, one for 16-18-18, and one for 15-17-17.  Lower numbers are tighter/faster, higher numbers are slower/looser for the timings.  Try slightly looser timings at 3200.  You can use the QVL to see what sort of timings other DIMMs are using in the 3000-3400 range.

It looks like the JEDEC default for your DIMMs is 17-17-17, but that's at 2400.  Maybe try 17-18-18-36 or 17-18-18-38 at 3200.  If you're system generally runs ok once it does boot, you are probably just right on the limit, and just backing off the numbers very slightly may solve the problem.

Level 7

This started for me on BIOS 4602, I also had to disable DOCP and manually set my ddr ram speed to 3600. I was getting constant BSOD in Windows and even tried the built in Windows recovery reset and removed files. I didn't try a full flash/reinstall of Windows.

I am on a X570-I strix board, ryzen 9 3900x, 7900 XTX. 

Super Moderator


It sounds as if the DOCP profile is applying some memory subsets that the system, or more importantly the CPU does not like at the given frequency. If selecting the primary timings, voltage and memory frequency manually is working - then it's probably best to simply use those.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090