cancel
Showing results for 
Search instead for 
Did you mean: 

tuf gaming x570 bios 5013

Vialli
Level 8

Just trying to see if anyone has upgraded and to ask if it's all good?

1,335 Views
1 ACCEPTED SOLUTION

Accepted Solutions

NotYou
Level 7

I upgraded from 4802  -> 50013 today, having intentionally skipped version 5003.

The only thing "odd" that I noticed this time was:
- prompted that "LED Firmware" was updating.  (never noticed this in previous upgrades)
- tPM Authorization requested.  (again, never noticed before)

All else went as normal, and nothing new in Device Manager was flagged.

View solution in original post

5 REPLIES 5

NotYou
Level 7

I upgraded from 4802  -> 50013 today, having intentionally skipped version 5003.

The only thing "odd" that I noticed this time was:
- prompted that "LED Firmware" was updating.  (never noticed this in previous upgrades)
- tPM Authorization requested.  (again, never noticed before)

All else went as normal, and nothing new in Device Manager was flagged.

Brilliant, will update later then.

Thank you very much.

Well, I changed my mobo today, ROG Crosshair Viii Hero, updated to latest..

johnmackiny1
Level 8

"Everything seems to be running smoothly, but I've noticed a decline in performance lately. When I compare the Cinebench results from when I first started using my CPU (5900x) with the BIOS version from 'that day' to the one from 'this day,' there's about a 10% drop." And if you'd like me to incorporate the term Bus Simulator, it could go something like this: "Everything seems to be running smoothly on my system, but I've noticed a decline in performance lately, especially when running the bus simulator.

lotsip
Level 7

Just upgraded to v. 5013, getting daily random freezes in windows 10.    Using default "optimized" settings. Any bios adjustments i should try?