Showing results for 
Search instead for 
Did you mean: 

ROG X570 Crosshair VIII Hero (Wi-Fi) BIOS 4402 issues with Ryzen Master?

Level 7
I'll try to make a long story short(er)....

So my PC has been completed since around August (with BIOS 4006), only piece of hardware that's been upgraded since then was my GPU, Asus Strix 3080 to an Asus Strix 4080. Since built, I noticed that somehow Windows installed the boot and recovery partitions on a different drive. I have two NVMe drives and wanted disk 1 (SN850 2TB) for OS and disk 0 (SN850X 2TB) dedicated for games. It bugged me for a while so over the weekend I finally did a clean install of Windows. I confirmed the partitions got placed on the correct disk, so I continued with the set up. I noticed Asus had an BIOS update (4402), so I installed that. Then I started the Windows updates, I let everything download and restarted as needed. One done, I restart to BIOS and set the RAM up correctly. Boot back to Windows and continued installed all my games, apps, drivers, AMD chipset drivers etc.

Ryzen Master is an app I use, and have been using. After I downloaded Ryzen Master, opened it and applied the values, ran stress test, passed and applied, all was fine for a little while. Ran Cinebench and was getting similar scores as before clean install. I'm happy, I continue to install my games. While I was playing a game, I got a blue screen with "IRQL_NOT_LESS_OR_EQUAL", and it would boot loop this screen. Spent hours trying to troubleshoot this, nothing worked. It would boot loop this same blue screen every time I restarted my PC. I went to Ryzen Master, thinking it was the OC/Curve settings, so I set everything back to default. Ryzen Master restarts the PC and it boot loops the blue screen. The random boot loops keep happening, so I do another clean install.

After this clean install, I installed everything but Ryzen Master and create a restore point. I'm ran a series of stress test, looping Cinebench for 15 mins, looping Time Spy. Restarted my PC multiple times, all seems to be fine. I then go to install Ryzen Master, and without applying any values my PC is back to boot looping that same blue screen. So I narrowed the issue down to being Ryzen Master. When it finally loaded Windows, I went into recovery mode and booted to safe mode. I restored back to the point I saved before installing Ryzen Master. PC restarts and all seems fine, until another blue screen, but this time "Critical Process Died" and it would not load Windows. Windows tried to repair but could not, so I had to do another install of Windows. This time I have no downloaded Ryzen Master and PC is completely fine.

I have not tried to downgrade BIOS to 4006 to see if that solves my issue, will try that later tonight.

PC running BIOS 4006 working with Ryzen Master
PC running BIOS 4402 NOT working with Ryzen Master

Known issue?