Showing results for 
Search instead for 
Did you mean: 

ROG Strix B550-F Gaming Wifi II with AMD Ryzen 9 5900X Won't POST

Level 7

Hello all, I'm having a very frustrating issue with a new build of mine. I have everything set up properly as far as I know. When I switch the PSU on the motherboard's cool little ROG logo lights up in all its colors etc but when I press the power button - nothing happens. I figured it might be a BIOS update issue to support the AMD Ryzen CPU so I followed all the instructions to flashback the BIOS update. That seemed to go smoothly without error, just to confirm I used the proper BIOS USB position as well as observed that it blinked until the light went out indicating it went successfully.

Other things I've tried:
- Used old PSU that I know works: Still the same result
- Removed all ram except one stick: Still the same result
- Completely reset CMOS( Removed cmos battery then used a screw driver to connect the clrtc pins)

I'm really going crazy at this point. Should I just return everything and switch back to my old gear? 


Level 7

I should add that none of the warning lights are lit up on the mother board.