cancel
Showing results for 
Search instead for 
Did you mean: 

Rog strix b450-f gaming

JCJMC
Level 7
In this thread we can put the news and doubts of the ROG STRIX B450-F GAMING.
New BIOS:
Version 1201
2018/12 / 288.36 MBytes
ROG STRIX B450-F GAMING BIOS 1201
Improve system performance.
Add CPU PCIe Lanes Unlocked item in BIOS when plugging in AMD Athlon 2XX series processors.
572 Views
98 REPLIES 98

DMAN999
Level 9
Asus B450 Beta BIOSes (Ryzen 5000 Support)
https://www.reddit.com/r/Amd/comments/jpa499/asus_b450_beta_bioses_ryzen_5000_support/

Version 4001 Beta Version
2020/11/24 10.68 MBytes
ROG STRIX B450-F GAMING BIOS 4001
1. Update AMD AM4 AGESA V2 PI 1.1.8.0 for new CPU support
2. It’s highly recommended not to update this beta BIOS when using AMD AM4 Socket for AMD Ryzen™ 3000 Series/ 2000 Series/ 1000 Series/ A-Series Desktop Processors.
3. This beta BIOS can’t be reversed.
https://rog.asus.com/us/motherboards/rog-strix/rog-strix-b450-f-gaming-model/helpdesk_bios/

DMAN999
Level 9
Version 4007
2020/12/09 10.75 MBytes
ROG STRIX B450-F GAMING BIOS 4007
1. New CPU support
2. Offer a Re-size BAR Support option to enhance GPU performance.

DMAN999
Level 9
Version 4101 Beta Version
2020/12/29 10.78 MBytes
ROG STRIX B450-F GAMING BIOS 4101
1. Improve system performance
2. Improve CrashFree function
3. Update AMD AM4 AGESA V2 PI 1.1.9.0.
https://rog.asus.com/us/motherboards/rog-strix/rog-strix-b450-f-gaming-model/helpdesk_bios/

Im using B450 F Gaming, i have error with new BIOS 4007 or 4101 Beta. When PC Started, after few second, Network, USB Devices, Sata Port and Audio will Disconnect. No Option downgrade to 3103 or 3003.

Any recommendations for B450-F BIOS versions?

I'm still running 2501 (from 2019-07) with my Ryzen 2600, but have a few sporadic issues. Lately: System sometimes completely unresponsive after simply idling (and monitor sleep set to one hour, usually just press button to wake monitor): Zero input devices work (keyboard, mouse), even PC power and restart buttons unresponsive! I have to shut off with PSU switch. So strange. Gaming and encoding perfect, but idling... nope!

Anyway, 2501 seems recommended a while ago. I just worry I'm missing out on some fixes and stability from newer versions in last two years. However, most newer versions have even worse reports from users. With no easy way to go back, seems like a gamble.

vanontom wrote:
Any recommendations for B450-F BIOS versions?

I'm still running 2501 (from 2019-07) with my Ryzen 2600, but have a few sporadic issues. Lately: System sometimes completely unresponsive after simply idling (and monitor sleep set to one hour, usually just press button to wake monitor): Zero input devices work (keyboard, mouse), even PC power and restart buttons unresponsive! I have to shut off with PSU switch. So strange. Gaming and encoding perfect, but idling... nope!

Anyway, 2501 seems recommended a while ago. I just worry I'm missing out on some fixes and stability from newer versions in last two years. However, most newer versions have even worse reports from users. With no easy way to go back, seems like a gamble.


I've been on 4007 with a ryzen 2700x for a month or so. Used have that same problem having to shut off the PSU switch but now that seems to be gone since updating. Can't say I've had any issues.

Hi everyone. I've Rog Strix B450-F Gaming. I'm using Windows 10 Pro 20H2 (19042.746)

I started broadcasting on Twitch. I installed the Twitch Soundtrack beta app and Sonic Studio III effects stopped working. When I uninstalled the Soundtrack App and Sonic Studio effects started working. This problem is very interesting. I hope Asus fixes this.

JCJMC
Level 7
Version 4602
2021/09/10 10.96 MBytes
ROG STRIX B450-F GAMING BIOS 4602
"1. Update AMD AM4 AGESA V2 PI 1.2.0.3 Patch C
2.Improve system performance"

Hi Guys,

i'm swapping my 1060 for a 3060 ti.
The debug LED isn't flashing through its sequence when I try to boot.
I'm guessing this means its either not attempting or failing POST.

The RGB light are turning on and all my fans are spinning so the motherboard is getting power.

I've tried removing components and reseating all connections. Its not even attempting post without a GPU connected.

i've also tried clearing CMOS with no effect.

any ideas?Â*