Showing results for 
Search instead for 
Did you mean: 

ROG Strix b450 F Gaming II will not display correct CPU Temp in Bios with Ryzen 5 5699G cpu installe

Level 7

I upgraded my wife's system with the ASUS ROG Strix B450-F Gaming II and a Ryzen 5 5600G processor.

The motherboard displays the correct temps in the bios with her old Ryzen 5 3600 cpu, but will not with the new one.  

It shows in red, -99 C no matter what I do -  I have updated to the latest bios, cleared CMOS, removed the battery and cleared CMOS, let the board sit with the battery removed and CMOS cleared for over an hour (as per instructions from Tech Spt), all to no avail.  I RMA'd the CPU with AMD, and the replacement does the same thing.  This happens in all my systems (I upgraded 3 computers in the family at the same time).  Yet, my daughters with a basic Ryzen 5 5600X shows temps fine, my pc with a Ryzen 5 3600 shows temps fine, and so does my wife's until I reinstall the Ryzen 5 5600G.

There is no overclocking involved, set all three systems to optimal settings, and tested the old, and the replacement CPU in all three, same issue - minus 99 C temp showing in bios in red when trying to run the 5600G.

Weird thing is, if I try to use HWMonitor, it shows a CPU Temp of +129 and a MB Temp of +132 or so,  yet the BIOS DOES display the correct MB temp.

Scroll down further in HWMonitor, and it shows a CPU Package temp at idle of around 32C.   So, something apparently is NOT getting read in the BIOS and is also NOT getting reported entirely correct to software.

To ensure preventing any damage I set fan to Turbo and also have tried a manual fan curve for the CPU.  While it seems to run everything just fine (Tried Handbrake and also Davinci  seem to run ok without any throttling)

Again, I have swapped CPUs and cannot get this to reproduce with any other CPU.  

Has anyone out there encountered anything similar?   ASUS did offer to RMA the motherboard, but I have reproduced the fault on multiple motherboards with both the original 5600G and the replacement.  Help?