Showing results for 
Search instead for 
Did you mean: 

ROG Crosshair VIII Dark Hero - BIOS detects SATA drives, Windows 10 doesnt

Level 7
I've just aquired this motherboard. My SATA drives are correctly detected in BIOS but when I run Windows 10 Disk Management half of my partitions/drives are missing.

Can you please suggest a solution? Or is the mobo faulty and needs to be RMAd?!

Thanks in advance for any feedback,


Level 7
BIOS version: 4006

SATA6G_4: WDC WD60EFRX-68L0BN1 (6001,1GB)
SATA6G_5: WDC WD181KRYZ-01AGBB0 (1800,2GB)
SATA6G_7: SAMSUNG SSD 850 EVO 500GB (500,1GB)

This is what my BIOS detects now. I have limited the connected drives to a minimum of the most essential ones. WDC WD181KRYZ-01AGBB0 doesnt show in windows disk management. This is my most essential WD Gold drive (contains the most valuable data, is the biggest, fastest and most expensive drive)

This drive worked before but WD60EFRX WD RED didnt instead. So I switched around the connectors and now its reversed. But no matter what I do I cant switch the drives around again. I need the GOLD drive to work desperately but I am clueless of how to acheive it.

Any suggestions please?

Thanks in advance.


I was forced to buy a cheap case to have my optical drive supported. Sharkoon S25-W. I've put my HDDs (WD RED, WD GOLD) into its cage and now I cant get them out. They're stuck in there and the manual doesnt provide instructions on cage demontage. My most expensive HDDs (800EUR) WD Gold and WD Red. :mad: Any idea what can be done?

Level 9
I don't have an answer, or any ideas. But you might try asking this in the 400 & 500 series part of the forum, this is for older boards.