cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Strix X470-I, latest bios 0601, and NVME drives

bmac1191
Level 7
I had a strange issue that ended with my NVME not being detected by the bios/motherboard. Of the few reviews of this board online at the moment, two of them are reporting issue with NVME drive not being detected - one is on amazon and one is on newegg.

It was working at first; I was able to do a clean w10 install. I installed the x470 chipset drivers, went to boot into safe mode, and was met with the boot up error to restart with a valid boot device. At this point the drive was still detectable in the bios. I tried all the bios boot options and nothing worked. I even did multiple secure erases on the drive, reflashed the latest bios, and reinstalled windows. When the windows installation went to reboot, I was again met with this boot drive error. I tried to reinstall windows like this a couple times. It was at one of those installation reboots that the bios stopped detecting the NVME.

Several times when I used the windows repair utility, it listed all the installs and wanted me to select one. I'm just wondering, where else does windows write to? If I erase the only drive on the system, reflash the bios, create a new w10 usb install device, how is it still finding installations?

Anyway, first go on downgrading the bios to 0403, the drive was detected and w10 installed correctly. Given the current reviews of the board and my experience, I would say there is something wrong with the latest 0601 bios.

Should I try installing 0601 again? I'm not sure I want to keep the board if I'm not able to run the latest bios.

Here is another post with a similar NVME issue -
https://rog.asus.com/forum/showthread.php?102287-m-2-NVMe-drive-not-recognized-in-X470-itx-gaming-mo...
2,497 Views
1 REPLY 1

aaraujo
Level 7
I am using a Samsung 970 Pro NVME drive without any issues with any BIOS version. What NVME drive are you using?