Showing results for 
Search instead for 
Did you mean: 

Potential Crosshair VII Hero issues?

Level 7
Hi. Hoping somebody can help me with this. I've had a *lot* of problems with this computer over the last year and it all seems to be somehow GPU-related (despite using multiple different GPUs), and nothing I've tried works, so I'm beginning to assume it's actually a problem either with my ASUS Crosshair VII Hero, or maybe my AMD RX3700 (I'm up-to-date with BIOS Firmware Version 4703 btw). I have a new ASUS TUF RX6800 and at the moment, it won't display anything, and I can't get it to work. This problem began a week ago when I left the PC on, went away for a while, and returned to a black screen with the PC in some kind of sleep/hibernation mode (despite that option not being on in Windows). I shut the PC down and tried to boot it again, but was faced with a constant bootloop and only sometimes was given the option to access the BIOS. Eventually, the bootloop would continue, but the BIOS start up screen wouldn't even show.

At one point I managed to finally get it to the Windows loading screen after clearing the CMOS multiple times, but the PC kept restarting in the middle of that too, and then after a few more times of that, it wouldn't get as far as the BIOS and kept restarting over and over and over again. I have a spare Nvidia GT730, and that seems to work perfectly well (it's also not PCI-E powered - no need for PSU cables). I've tried both GPUs plugged in at the same time and it seemed to make the RX6800 almost work again by getting as far as the Windows logo, but the system restarted and the bootloop issue continued as before. I'll add a list of things I've done to try and fix this already at the end of the post. Right now, I'm using the GT730 in one PCI-E slot, and the RX6800 in the main PCI-E slot with the PSU cables disconnected, and everything is stable.

So here's where things get complicated - earlier this year in February I was using an Nvidia RTX 2070 Super, and the same issue came up for that too. That GPU was under relatively heavy load gaming for maybe an hour, and the computer just completely shut down in the middle of use. Since then, the PC would start, but there was no display. The GPU powered on with the fans at 100% and the usual RGB lighting, but still wouldn't display anything. I got a refund on it from Amazon (despite it being well past its warranty, lol), and replaced it with this RX6800. Again, the GT730 I have worked perfectly fine then too. I've also used two different PSUs, and it hasn't made a difference.

Here are my specs:

ASUS X470 ROG Crosshair VII Hero
AMD Ryzen 3700x
EVGA SuperNOVA 750 G2 80+ GOLD 750W
4 x 8GB Corsair Vengeance 3000mhz RAM

Here's what else I've tested:

  • using only one stick of RAM
  • using only one hard drive*
  • disconnecting all hard drives just to see if I could at least get a boot error on screen
  • Memtest64 shows no errors (I've done this multiple times over the months)
  • CMOS resets - sometimes several times a day
  • Default BIOS settings when I'm able to access the BIOS
  • Tested both PCI-E slots with the GT730 and RX6800, and long before with the previously owned RTX 2070 Super
  • Tried a new EVGA SuperNOVA 750 G5*PSU in place of my EVGA SuperNOVA 750 G2*PSU
  • Stress tested the CPU with 3DMark to see if the CPU has issues
  • New thermal paste applied to CPU

I'm really at a loss with what to try next. I've even recently disconnected everything, cleaned the case and the components, reconnected, and no change. Is there a motherboard/BIOS issue that could be causing this? Or anything else I could try?

Thanks for any help, and apologies that this post is so long.

Level 7
Just as an update: I booted into safe mode with the GT730, used DDU display driver remover to remove all traces of the AMD driver, then shut the PC down, plugged the PSU back into the RX6800, and the bootloop continued again with no BIOS screen. Unplugged the GPU and I'm back to using the GT730 again.