Showing results for 
Search instead for 
Did you mean: 

Post code 22 after + DRAM LED on, after bios update to 4402

Level 7

Hello everyone, I hope someone can help me.

My problem is: after I updated my bios to version 4402 (release 2023/02/08) and after setting the bios according to the settings that I need, as to say, CPU fan set to "ignore" because of my Nzxt AIO cooler, ad my Hyper x Predator ram to "3200hz", when I shut down my PC and power it back on I get stuck in q-code 22 with the DRAM LED on, then if I reset the pc through the button it posts normally and load into Windows. I've to precise that I've never had any problem with my RAM before and they have been working since i built my PC in nov. 2020, so i doubt that it could be a strictly related RAM problem.

Do you guys have any idea what the problem could be?


My specs are:

- Asus  ROG CROSSHAIR VIII HERO(WI-FI) motherboard 

-Ryzen 9 3900xt CPU

- 4x 8 GB RAM HyperX Predator 3200hz max

-GPU Asus ROG RTX 3070ti

-Cooler NZXT AIO Kraken Z73 360mm

-Asus ROG Thor 1200w PSU


Level 7


Hi everyone, today I had the chance to update AMD chipset and my graphics drivers, after both of those processes I shutted down my PC and turned it back on, after the chipset update the problem seemed solved. I'll keep the post updated in case problem comes back.

Level 7


Hello everyone, hope you all are doing good. It's been some days after my last update, suddenly my PC give the same error again on start up and as before if I reset the system the PC will boot normally, so chipset update didn't fix the prblem. If someone has any idea on what it could be, please let me know, this problem is bothering me quite a lot. Thanks!