cancel
Showing results for 
Search instead for 
Did you mean: 

NZXT Powered Internal USB Hub -> Possible BIOS lockup issues / freezes; Windows crash

lightknightrr
Level 7
This is an intermittent bug, but does seem to be traced back to this hub. Background: since Asus gave us only 2 internal USB 2.0 ports, and many of us are using cases with at least 2 external case USB 2.0 connectors with internal headers, plus something like a water-cooled processor (which has a USB cable for feedback, thank you Corsair) and possibly something like a USB cable from the power supply (for power use feedback, thank you Thermaltake), 2 internal USB 2.0 ports are not enough. Solution? Use an internal hub to expand the number of ports. Better solution? Use a 'powered' internal hub, because powered is usually better.

NZXT's hub seems like a fine solution there...except it apparently doesn't respond to requests to reset the hub (controller). At least, not all the time. Sometimes it will boot fine, other times, you will end up on a screen that shows "American Megatrends", their logo, and nothing else; unplugging the hub (possibly rebooting) allows it to boot normally; plugging the hub in while the computer is on seems to have it working again fine.

Once the problem manifests, not even a BIOS reflash (with a BIOS reprogrammer) will fix it; the hub has to be unplugged. Turning off the machine, killing the power supply switch does not seem to work either. No idea if there is a stored charge that needs to be dissipated, not willing to wait the several days needed to find out.

Short term solution is switching to unpowered hubs (4-port Amazon Basic Hubs), and installing the appropriate male & female internal to external headers to connect everything up. I currently have mine on order.

No idea if this is a NZXT bug, an Asus bug, an AMD bug, or (somehow) an ASMedia bug.
141 Views
23 REPLIES 23

lightknightrr
Level 7
I think I'll swap some of my other hubs, just to be on the safe side...

FireRx
Level 11
Asus, Please TALK NOTE: and return to 2 minimum USB 2.0 connection on the motherboards. Most of us use AIO water coolers with data cables that use one of the connectors. Don't know who in you design team those people didn't need more than one. So now I have to make a choice between having usb front the front of my case or monitor my pump and fan data from my cooler. 😞
Intel Core i9 103900KS
Asus Maximus Z790 Extreme [bios 1801]
LG (34U97-s) Monitor 3440 x1440
Nvidia RTX 3090 FE
Windows 11 Pro
64gbz Memory

lightknightrr
Level 7
Yup, Amazon Basic hubs (10-port) can impact RAM speed as well (one machine won't boot with a hub attached (gets stuck at the BIOS), another machine with a different hub (same make) won't hit 3200Mhz).

Ravwyn
Level 7
Just to add some info on this, for anyone who finds this post after soooo long too: Had the exact same issue here -> Random hard freezes, reboots that got increasingly bad. I thought I suddenly had the RTX bug (after the 3070 worked fine for months). Drove me crazy. Ended up pulling the NZXT Hub and discarding my RM650i's monitoring entirely, solved this behavior 100%. No crash/freeze since yesterday. Super weird, but this USB Hub seems to be causing shorts or something else that triggers the C6H to simply restart.

Hope this helps, have a good one 😃