Showing results for 
Search instead for 
Did you mean: 

NVME raid Windows installation problems..

Level 8
Actually the problem is not about installing Windows but booting that installed Windows...

So, I built my system last weekend.

MB: Asus ROG Strix X570-E Gaming
CPU: Ryzen 5900X
GPU: Asus RTX 3080
RAM: 4x32 GB Patriot Viper 3600 MHz.
NVME: 2xSamsung PM9A1 2 TB Gen4 drives.
SATA: Ranging from 2 TB to 12 TB, several drives.

There were some hiccups when building like stuck in Q-code "02", not seeing M.2 drives at BIOS. I solved "02" problem with updating BIOS via BIOS Flashback, and ignored the other one because it seems it's ok if they're not there ( is it? ). Maybe I should clarify this. I don't see the NVME drives in AHCI mode, but I can see them in RaidXpert2 clearly.

Anyway.. I configured BIOS like this:

Enabled SATA RAID, and NVME RAID, Entered RaidXpert2 Configuration and Created a new RAID0 array with my two NVME drives. BTW, I'm still not sure enabling SATA RAID is really required, although AMD documentation says Enable, not sure why.

Disabled Launch CSM ( Weird thing, AMD's documentation says enable CSM, but I read disable on other places )

Set Secure Boot to Windows UEFI etc.

I didn't see RAID drivers on ASUS support site. There is one but it's for installing on Windows not for putting in USB. Clearly I should have checked DVD came with the drive.. You know, everybody should have some kind of DVD drive to read those DVDs... Some suppliers give USB driver disks now, ASUS should learn from them.

Anyway I downloaded those RAID drivers directly from AMD, deciding it would be more up to date anyway. Created my Windows 10 Enterprise install media via Rufus, put drivers in it and booted. I don't know why it shows two UEFI devices when I insert only one drive, but only one of them boots so no problem there..

After booting I loaded rcbottom, rcraid and rcconfig drivers with this order. After rcraid I saw my NVME RAID drive and other SATA drives. I selected my NVME drive and installed Windows.. There was no problem at all...

The problem was after reboot.. There is nothing.. I mean nothing on BIOS, nothing on boot.. There is no indication that a Windows installation exists anywhere.. I also looked up videos of Windows 10 installation on NVME raid and there is no indication that I need to switch a BIOS setting or something on them.

So what's my problem.. What am I doing wrong? How can I boot the Windows I installed?

Level 8
Just found out that while creating the Windows partition I only select "Next".. Normally if you have no active Windows installation, Windows creates an EFI "System" partition, "MSR" partition and "Recovery" partition along with Windows partition.. But because one of the disks I put in the system already had a Windows installation I think it didn't create those. Selecting "New" on the partition though creates those.

So, after clicking "New" instead of "Next" it did create all necessary partitions and finally booted Windows.