cancel
Showing results for 
Search instead for 
Did you mean: 

New Ryzen 5000 Build Troubleshooting Help

Snoopwolf
Level 7
Hello, I wasn't sure where to put it so I hope it's fine here. I've been trying to figure out what's up with my pc but so far I'm puzzled.

I've built a new pc less than a month ago and been having a few hiccups. The issue is every few hours or so, the entire pc will stutter/lag for a very brief time (typically roughly 1/2 to 3 sec.). This affect both the visual and audio aspects of whatever I'm doing. Everything slows down and the audio gets distorted. It doesn't appear to mater what kind of load is put on the system, I could be browsing the internet/watching videos up to playing intensive games for hours and I will still get that problem.

I've tried many things and I'm at a point where I might have to swap major components/start almost from zero to potentially fix the issue. Before going down that road, I'd be happy if I could get some opinions or advice. I'll be listing my build below and what I've tried so far to solve the issue.

Build:

-OS: Windows 10 Home 64-bit (10.o, Build 19043)

-Motherboard: Asus ROG Crosshair VII Dark Hero X570 (BIOS 3801)

-CPU: AMD Ryzen 9 5900x*

-RAM: Corsair Vengeance RGB Pro SL 2x16GB 3200MHz (CMH32GX4M2E3200C16)

-GPU: Asus ROG Strix GTX 1080 ti 11G*

-Storage: 1x Western Digital WD Black SN850 NVME M.2 SSD PCIE Gen4x4 (500GB)
1x Western Digital WD Black SN750 NVME M.2 SSD PCIE Gen3x4 w/ Heatsink (1TB)

-PSU: Corsair RM1000x (2021) 1000W

-Case: Corsair Obsidian 900D

*Both CPU and GPU are watercooled using EK waterblocks, D5 pump and 2x480mm radiators so overheating shouldn't be an issue.

Tried so far:

-Most recent BIOS vs Older BIOS

-Changing BIOS settings: C-states on/off; PCIE Gen 4/3/Auto; Stock CPU/slight PBO undervolting; Stock/Auto/DOCP RAM profiles

-Running Disk check and system check multiple times. Found some corrupted files once (out of 10+ scans) and corrected them

-Running Memtest86 => Passed every time I ran it.

-Fresh windows install along fresh drivers (chipset, graphics, audio, etc) => tried multiple times with older and newer versions and followed installation guides for the Realtek Audio Drivers, DDU clean Nvidia driver install/Geforce/Standalone...

-Changing power plans Balanced/Max performance along with removing any power saving settings for all devices (ethernet, gpu, etc)

-Install/Un-installed softwares: Armory Crate, Asus AI suite, Corsair iCUE, along with some apps and other less critical programs to try to keep the install clean.

-Running on WI-FI vs Ethernet (Keep getting a warning in the event viewer that the Intel I211 Gigabit Network link is disconnected even when not in use event ID 27)

-Manually disabling HEPT, unused/non critical services and most programs in startup

-Cleanup Windows (Storage sense/Temp files); Turn off unused windows features like notifications and tablet mode; Adjust System settings for performance.

-Set devices drivers to run on MSI vs IRQ; Disable temporarily unused devices drivers

-Brand new surge protector power bar (to rule out the older one even though it seems to work fine)

-GPU powered by 2 separate 2+6 cables vs 1 split 2x 2+6; Also tried my older Asus Strix GTX 970 4GB (Been sitting in it's box for a couple of years and I don't remember if it had any sort of issue or if it was running fine); Tried on both top and middle PCIE slots.

-Single vs Dual Monitor + HDMI vs DisplayPort (If I plug only my 1440p monitor in the first DP the VGA white light stays ON (motherboard). Potentially due to my pc booting faster then that monitor. When I plug just my 1080p or my 1080p in the 1st DP and my 1440p in the second one, no VGA white light on the motherboard)

-Before using the brand new Corsair RM1000x I was using a Corsair RM850i => Not a PSU issue

-I was using a Ryzen 7 5800x before switching to a Ryzen 9 5900x => Not a CPU issue

-Fans and water pump appears to be running normally (no crazy noise/RPM); No CPU thermal throttling; GPU is running at very most under stress around 40-50°c

-Finally I've tried to swap both M.2 SSDs from top and bottom ports and only running the OS (WD SN850) one with some older SATA SSDs

Potential routes I have in mind as of now:

1- I haven't tried installing the OS on older drives/Ruling out the WD SN850 since it's brand new and bought at the same time as my CPU/Motherboard. I might try it but I'm doubtful it will be any different.
EDIT: Just ruled out the SN850. Installed my OS to a separate drive and removed the SN850 from the build and the issue still persists.

2- My RAM isn't on the QVL of my motherboard but is advertised as being "optimized for Ryzen". I've had Intel builds before and never had RAM compatibility issues and might have overlooked that part. I wasn't aware that Ryzen tends to be picky on RAM before later reading about it but at the same time, and I could be wrong on this, I don't think I would be able to boot into Windows and do everyday stuff without crashing.

3- My GPU was bought used a few years ago. Although I've never had issues with it before it doesn't mean it couldn't be malfunctioning and my older GTX 970 isn't necessarily a reference.

4- Unlucky and less likely would be a faulty motherboard.

That's all I have for now. Keep in mind all the things I tried that are listed are the ones I remember on the top of my head. I've read so much stuff online I might have tried some other tweaks/fixes that I don't remember. This issue is driving me nuts since I can't seem to put the finger on it regardless of what I do and I absolutely need to have this pc working for online CAD classes and work so RMA the motherboard would be a solution of last resort.

Thank you for taking the time to read my post!
4,601 Views
23 REPLIES 23

Snoopwolf
Level 7
I know that for some people it did fix some similar issues as strange as it sounds but either configs for the E-ATX connectors (8 pins vs 8 + 4 pins) had no significant effect in my case.

Unless the motherboard was somehow damaged when I installed the EK cpu water block, I've ruled out overtightening after trying an another AIO I had in backup which uses the stock AM4 mounts. Tightening slightly more then required with that cooler would only result in bending/flexing the fairly thin bracket holding the block/pump assembly. While testing this, I was running my setup out of the case on a non-conductive surface to rule out any case screws or standoffs potentially shorting. No luck there again.

RAM passed Memtest86 so I just tried to stress test both sticks individually with OCCT. I'm limited to 1hour test with the free version so I'm not sure if it's enough to have errors show up but in the end, there were no errors, no BSOD or crash.

What's even more strange is that yesterday I used my pc for a couple of hours until a short hiccup happened. After coming back from diner, I restarted the pc and it ran fine until I went to sleep fairly late into the night.

Something else that I have noticed is that sometimes I'll randomly get temperatures spikes up to around 70-75°c (it was also doing this with the 5800x). I'm not sure if it could be related or not; Could just be my anti-virus, windows update or another app running in the back otherwise at idle/low load it's around 30-40°c and 60-ish on more moderate/high intensive loads (I thought I'd mention it after hearing about motherboards with faulty temp. probes). Since I've been used to cooler CPUs from Intel, It could mean nothing at all, I know AMD have their CPUs running fairly hot and I'm still getting used to this lmao.

I'll keep monitoring and post up if anything else comes up. Thanks for the help so far, it's helping me a lot to rethink what I have or haven't tried or if I've made a mistake somewhere.

RedSector73
Level 12
The temp is junction temp in the CPU, which is why see 70-75 suddenly, if you were not on water be like high 80's.

Let's see if I understand correctly... as a summary.

Your 5800x never had an issue like this, on the same motherboard using the same RAM.
Your 5900x is having an issue, on the same motherboard using the same RAM.

------------------------------------------------------------

Have we tried resetting the BIOS to factory defaults, then setting everything back to right not using a save profile ?

Snoopwolf
Level 7
Sorry I should have made it more clear in my original post, I was having the same issues with the 5800x and since the 5900x ended up being on sale, I decided to try changing for the 5900x to rule out a faulty CPU and getting a better one (two birds one stone kind of situation).

Now that you mention it, I don't think I've tried to revert to factory BIOS. It was one of the first if not the first thing I updated on this build. If I recall correctly though, the BIOS version it came with wasn't particularly old/far behind the newest one but I guess it wouldn't hurt to try it. As far as BIOS settings, I believe I've tried using both default values and custom ones (DOCP + small undervolting) but I guess I could try again and make sure on that front too.

I'll give it a try and see how it goes.

RedSector73
Level 12
No undervolting either and see how it goes. Just DOCP and AUTO everything else.

RedSector73 wrote:
No undervolting either and see how it goes. Just DOCP and AUTO everything else.


Tried DOCP and everything else at stock settings/auto and issue showed up around 2 hours after bootup. That's on latest BIOS (3801). It might sound strange but I feel it took longer for the issue to show up with an undervolt of 10 compared to using stock settings. I wanna say roughly twice as long in between episodes.

RedSector73
Level 12
Run memtest86 test with these default settings (DOCP / AUTO) and see if the ram throws errors
https://www.memtest86.com/

Snoopwolf
Level 7
So I ran memtest86 with the same settings (DOCP and everything else AUTO), 1 stick at a time, and there were no errors even though I was hoping something would show up. I don't know what to try next. Testing the GPU over several hours? Different set of Ram from QVL? New motherboard? Don't see that many options left. It's been pretty frustrating trying to find the source. Even though it will work fine 90% of the time with great performance, I have to be honest this whole thing made me question my build choices.

Snoopwolf
Level 7
I decided trying with a different set of ram. The issue is still present.

RedSector73
Level 12
Well, the odds of having two bad CPUs and two sets of RAM, must be close to zero. Have you hit ticked support on ASUS about RMA of motherboard because I can't think of anything else, you have trouble shot every thing else. What else could it be ?

Snoopwolf
Level 7
Ok so in a last ditch effort to try to resolve my problems before initiating a RMA process, I was poking around my case looking for anything I oversighted and one of my water cooling tube got loose and started leaking in my case (this is the kind of luck I've been having lately lol)... I ended up completely dismantling my pc to cleanup the mess it did, dry off everything overnight, and then redo the loop. After that little adventure, I then proceeded as follow:

-Flash BIOS to older version for the Crosshair Dark Hero (3601 vs 3801 which is the newest) and then manually set RAM speed and timings everything else on auto.

-Fresh windows install (No internet and therefore no Microsoft account linking)

-Manual update of Nvidia Drivers, AMD Chipsets and other drivers (Downloaded beforehand on a USB drive)

-Restart - Connect Wifi/ethernet - Windows Updates - Rinse repeat

-Manually Install Realtek Audio Drivers following this procedure (Thanks to MoKiChU BTW) : https://rog.asus.com/forum/showthread.php?117596-DRIVERS-Realtek-Audio-(MB-Intel-2xx-3xx-4xx-5xx-amp...

-Progressively re-install other drivers and softwares (Armoury Crate/Corsair iCue/etc)

So far, I've used my pc for 8-12h for the past 2 days and I don't want to jinx myself but I'm happy to say I haven't had any major hiccup or stuttering issue since then. I'll still have to test running my RAM at higher speed since it's not running at full capacity and also maybe try again on the cpu undervolting. In any case, if the issue comes back then I'll start a RMA process but so far so good!