Showing results for 
Search instead for 
Did you mean: 

Motherboard Acting Weird After PSU Replacement

Level 8


As the title suggests, after I switched my PSU from a ThermalTake ToughPower Grand RGB 1050w to an MSI MEG Ai1300P 1300w Platinum ATX 3.0, it started acting weird, at first it wouldn’t boot and I had the power cables plugged in as 8 + 4 the 4 was using half an extension because my PSU came with 2x 8 pin CPU cables but they are not the split type unfortunately but anyway that’s not the issue, I ended up only using 8 pin which was working fine before, I plugged in all the cables and made sure they’re plugged in properly, after that I tried to boot up and it did work the first time but my mouse wasn’t moving so i felt it was weird and my network connection wasn’t working either, so I decided to restart and then my mobo would get stuck on the GPU light, so I was worried something happened there and tried to switch to another 12VHPWR adapter that originally came with my 4090 and it was working earlier, but again same issue, so I switched back to the ATX 3 12VHPWR that came with the PSU again.

After that it occurred to me that I also plugged in an M.2 expansion card and it might be getting stuck on that instead, and I was right, after I unplugged that it booted up but again no internet and mouse won’t move, I tried removing all USBs other than mouse and keyboard and that fixed my mouse but couldn’t get my internet or on board wifi or Bluetooth to work..

I also tried resetting the bios by shorting the bios pins but once booted it also doesn’t detect Ethernet, wifi or Bluetooth, I’m not really sure what the issue is.. did my bios get corrupted accidentally when switching the PSU? Also when I try to shutdown it won’t turn off and it’ll get stuck on Q-Code 04 after the screen turns of, I can restart it normally.

Lastly my 2nd m.2 SSD causes my mobo to get stuck on VGA white light if plugged.

System specs:

Ryzen 7 5800X3D
CORSAIR VENGEANCE DDR4 64GB 3600Mhz (currently at 3200 since I reset the bios)
ASUS STRIX X570-E Gaming WiFi II
MSI MEG Ai1300P 1300w 80+ Platinum ATX 3.0

Please let me know if you have any idea what else I can do? I was thinking of downloading the latest mobo bios and flashing it but I’ll have to get it from work today since I don’t have easy access to windows pc..

The two primary issues I'm having are:

1. I cannot use any of the on-board Ethernet, Wi-Fi or Bluetooth.
2. If I plug my 2nd M.2 Slot in, PC will get stuck on VGA light and won't boot, This includes plugging it in via PCIE Extender.
3. When I shutdown, the motherboard gets stuck on 04 after turning off the display and it won't fully shutdown unless I force click the button.


Super Moderator



1. Disable DOCP

2. Check Device Manager for any flags. Make sure to redownload and install all necessary device drivers from the support portal.

3. Flash to UEFI 4802 for AGESA 1.2.0.A

4. Go to Control Panel > Hardware & Sound > Power Options. Select AMD Ryzen High Performance > Change advanced power settings > PCI Express > Change Link State Power Management to Off.

5. Additional Power Settings > Choose What the Power Buttons Do. Click "Change Settings That Are Currently Unavailable" and uncheck Turn On Fast Startup.

See if any of these steps help.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Thanks for the reply, I'll try out these things when I get home and i'll update on whether it worked or not.

Level 8

I have concluded that there might be a fault with PCH, so I'll request an RMA, in the mean time I might switch to an ROG Crosshair VIII Hero.

Level 8

UPDATE: Replacing the motherboard did fix the issue, it was a motherboard problem unfortunately ..