cancel
Showing results for 
Search instead for 
Did you mean: 

MODDED BIOS FILES EFI Intel RAID ROM 15.1.0.2545 Download

BOLTS4BREKFAST
Level 12
**ALL FILES UPDATED WITH LATEST MICROCODE - MARCH 11 2018 - 6:15PM EST**

https://1drv.ms/f/s!Amy65Cmu51iJz0W2-V6VlOozxl7K

*That link should take you to the main folder where you can find the motherboard model you want along with the bios version.*
*NVME TESTING folder contains BIOS files that have been modded for NVME support*

*if you have a special request for another bios revision just post on this thread or PM me... please be patient since for some reason I no longer receive email notifications from Asus Forum when I get PM's or to subscribed threads.*

**if you'd like to make a donation follow the link below. Thank you!**
https://www.paypal.me/gmpcrepair

**MUST BE FLASHED USING BIOS FLASHBACK METHOD**
http://event.asus.com/2012/mb/usb_bios_flashback_guide/
NZXT Phantom 820
Asus Rampage IV Extreme
NZXT HALE90v2 1200w PSU
Intel i7 3960X OC'd @ 4.7Ghz
Corsair H100i (Push/Pull)
MSI GAMING 4G GTX 980
16GB Corsair Dominator GT 2133Mhz
2 Samsung 840 Pro 256GB SSD's (RAID-0)
2 Samsung 850 Pro 256GB SSD's (RAID-0)
SoundBlaster Z PCIe Sound Card
Logitech Z906 5.1 Surround Sound
Sennheiser PC360 Headset
LG Blu-Ray Burner
Windows 10 Professional 64-bit
449,150 Views
665 REPLIES 665

mitzatomitza
Level 7
All I can do is to flash to the original 0801 bios from ASUS website 7/14/2014. After flashing to the original bios I tried again to flash the RIVBE 4804... nothing!!!

mitzatomitza
Level 7
I think I am getting an trunkated /incomplete download from the link provided by #BOLTS4BREKFAST.
Can anyone provide a link to a working RIVBE bios ?
Thanks!

No luck with the NVMe BIOS on Rampage IV Formula sadly. Tried installing a Seagate BarraCuda 510 on a Micro Connectors PCIE-M20802HS. I got a bit further with the modded BIOS when trying to install Windows at least. Instead of receiving an error saying Windows couldn't install I was able to go through the initial installation process but sadly it would only blue screen after restarting and trying to get devices ready.

For now I've just thrown on a SATA M.2 drive but it would be nice to be able to use an NVMe. Any suggestions or am I just SOL here?

Does anyone have the fresh link? the one drive account seems to have dissapeared?

nvan7891
Level 7
I found this, but it's for the Rampage IV Formula.

https://www.win-raid.com/t6675f44-OFFER-Asus-Rampage-IV-Formula-NVMe-BIOS-mod.html

Just in case anyone who needs it looks here. I know I did.

Edit: This is an nvme mod.

anhelllin
Level 7
Hello, OP, are you still updating it? Would you perhaps have one for my MOBO Maximus IV Gene-Z (not /Gen-3)?
And that would mean that I could use a NVME to PCI-E adapter to boot?