cancel
Showing results for 
Search instead for 
Did you mean: 

Lost Pstates Stuff in BIOS 2703

Ken429
Level 7
Hero VII BIOS 2703 Pstates gone?
Just updated my ROG Crosshair VII Hero motherboard from BIOS version 2501 to 2703. For some reason the Custom Pstates/Throttling stuff is no longer available under Advanced>AMD CMS in the BIOS. Is there some magic I need to be aware of to get this to show or has it been eliminated somewhere in the last two or three BIOS updates that I missed? Help appreciated.
393 Views
4 REPLIES 4

TechyInAZ
Level 7
Ken429 wrote:
Hero VII BIOS 2703 Pstates gone?
Just updated my ROG Crosshair VII Hero motherboard from BIOS version 2501 to 2703. For some reason the Custom Pstates/Throttling stuff is no longer available under Advanced>AMD CMS in the BIOS. Is there some magic I need to be aware of to get this to show or has it been eliminated somewhere in the last two or three BIOS updates that I missed? Help appreciated.


That's an old bios now, 2801 just came out a few days ago. I suggest you install that one.

TechyInAZ wrote:
That's an old bios now, 2801 just came out a few days ago. I suggest you install that one.


+1

2703 was probably the most buggy bios released. 2801 is my favorite so far next to 2501.

I'm missing something! Pstates settings will not show in the BIOS. It ain't the BIOS since I've got the same problem with 2801 that I had with 2703. Back in 2501 it all worked as advertised. Can someone please clue me in on what the heck I'm doing wrong or what changed with the newer BiOS's. I've tried clearing the BiOS and reloading the Defaults but it has on effect - I can't find the Pstates. I'm sure it's something stupid but...help appreciated.

Ken429
Level 7
What else do I need to do to get some help with the "Missing" Pstates problem I'm having with the C7H MB? Did they get moved to another location in the BIOS?