cancel
Showing results for 
Search instead for 
Did you mean: 

Latest C7H BIOS

Shamino
Moderator
211,901 Views
492 REPLIES 492

xeizo wrote:
MSI have faith in 1.0.0.3AB:

[MSI] AM4 BIOS Update (7/23/2019).
X470 GAMING PRO CARBON/AC BIOS-7B78v19/29.
X470 GAMING PLUS BIOS-7B79vAB.
B450 GAMING PRO CARBON AC BIOS-7B85v17.
B450 GAMING PLUS BIOS-7B86v19.
B450I GAMING PLUS AC BIOS-7A40vA7.
1.Update AMD ComboAM4 PI 1.0.0.3AB.
2.Fix RAID issue.

B450 TOMAHAWK BIOS-7C02v19.
B450M MORTAR TITANIUM BIOS-7B89vA7.
B450M MORTAR BIOS-7B89v18.
B450M BAZOOKA PLUS BIOS-7B90v17.
1.Update AMD ComboAM4 PI 1.0.0.3AB.
2.Fix RAID issue.


Not just MSI but Gigabyte and also ASRock seem to have no issues with it. Typical ASUS bringing up the rear on their firmware releases - almost like we have to wait for the next release of AGESA to get the one before :mad:

[Thanks for all the kind comments on my modded bios. Yeah I know a bit confusing but here my forum name is TaijRai over on OCN it just MTRai.

TaijRai wrote:
[Thanks for all the kind comments on my modded bios. Yeah I know a bit confusing but here my forum name is TaijRai over on OCN it just MTRai.


You deserve it @TaijRai !

Still trying to wrap my head about how to go about modding these myself, would appreciate any pointers or links to research material you could give me. There is information overload out there, and I can sift through it all just haven't had much time yet, I know you don't have much time either, but if you had links to some crash course reading to get me started, that would be awesome! Obviously, your a busy man, so I will still sing your praises if you don't have time! I appreciate you regardless!

gupsterg
Level 13
@Shamino

VTTDDR when left on [Auto] does not become 1/2 of VDIMM, another has also noted this. I noticed this today when I set it as [Auto], this was on UEFI 2501. I'm pretty sure UEFI 2406 would also exhibit this behaviour as they are so similar. I had not noted this usually set my own value manually.

Also I believe ASUS WMI is broken on UEFI 2501. I had no other apps accessing SIO except HWINFO open for last night's of HCI and PWM was lost on headers. Organise files by date in this ZIP. I did a RAM Test run from POST from shutdown, then on same POST, then on restart from OS, then HCI on restart from OS.
Intel Defector :eek: AMD Rebel


R9 5900X - Custom WC - ASUS Crosshair VII Hero WiFi - Ballistix Sport LT 2x16GB 3800MHz C16 - RX 6800 XT - WD SN770 2TB - 2x 870 EVO 4TB


24/7 OC: i5 4690K @ 4.9GHz CPU@1.255v 4.4GHz Cache@1.10v - Archon SB-E X2 - Asus Maximus VII Ranger
Sapphire Fury X (1145/545 ~17.7K GS 3DM FS)

:eek: CPU Validation 5.198GHz@1.314v with 4.4GHz cache + RAM 2400MHz@1T :eek:
Da Music video

xeizo
Level 12
I gave up on 3900X since nowhere to be found, but I have a 3700X waiting for being picked up. A new bios right now would be very appropriate for me 🙂
R9 7950X - ASUS X670E Crosshair Extreme (bios 0803) - 32GB HyperX Fury Beast @6200c32 - Corsair H150i Pro - ASUS RTX3080 TUF OC V2 - Phanteks P400A - Corsair RM850 - WD SN850

xeizo
Level 12
The 3700X has arrived, soon we will see if it boots ...

Pity there's still no new bios, looks like there's really need for one!
R9 7950X - ASUS X670E Crosshair Extreme (bios 0803) - 32GB HyperX Fury Beast @6200c32 - Corsair H150i Pro - ASUS RTX3080 TUF OC V2 - Phanteks P400A - Corsair RM850 - WD SN850

I'm giving serious considering to returning my Crosshair VII X470. Considering that Asus still haven't even released the launch BIOS (1.0.0.03AB) almost 3 weeks after the launch of Ryzen 3xxx, I've lost faith in them to actually do anything.

Other manufacturers have managed to get this out and constantly improving their releases, whereas Asus can't even provide an ETA. Yes 1.0.0.3AB isn't perfect, especially compared to the buggy 1.0.0.3ABA, but it's better than being on a firmware that's well behind even what was recommended at launch.

The Crosshair VII was a great fit to what I actually wanted in terms of layout, feature set etc. but support is also key to me and I don't feel like any of us are getting it - more the fantastic community that's driving this forward. I'll hand my money over to another manufacturer that actually cares about customer experience.

thedotlair wrote:
I'm giving serious considering to returning my Crosshair VII X470. Considering that Asus still haven't even released the launch BIOS (1.0.0.03AB) almost 3 weeks after the launch of Ryzen 3xxx, I've lost faith in them to actually do anything.


yep thinking the same.

i just bought another CH7 because i hate the fan on the x570 boards and they are overpriced.
but asus seems to have droped the ball on the ryzen 3000 release.

xeizo
Level 12
3700X in the box, bios 2501, performs rather close to as advertised with this initial testing. I managed to squeeze 95W out of it though 🙂






81149
R9 7950X - ASUS X670E Crosshair Extreme (bios 0803) - 32GB HyperX Fury Beast @6200c32 - Corsair H150i Pro - ASUS RTX3080 TUF OC V2 - Phanteks P400A - Corsair RM850 - WD SN850

Well hopefully Asus is working on the new BIOS'es, if AMD has provided one newer than 1.0.0.3ABA without those bugs

Also, hopefully they listen, and do the small quality of life (and not making us go deaf) changes..
Those being..
Letting -us- control fans, even over 72c.
Allowing us to disaple HPET if we want to.
Allowing us to disable spread spectrum if we want to.


My old z68 extreme4 motherboard from asrock allowed all 3, it was a .. 2009-2010 board?, cmon.