Showing results for 
Search instead for 
Did you mean: 

fTPM I/O Error with Crosshair VII Hero and Ryzen 2700x

Level 7


Crosshair VII Hero

Ryzen 2700x

16GB DDR4 3200mhz


I have already tried testing with bios 5102 and 4301.

If I leave "fTPM" Enabled in the bios, windows 10 will show a BSOD talking about an "I/O" Error with winload.efi.

I did wipe the sata SSD clean and tried to install windows 10 on it, but I still got a I/O error anyway.

So I looked around the internet. One person talked about how the Ryzen 1000 and 2000 series processors do not have TPM in them even though the 2700x is listed on their page. Another fellow I was talking to said that they were able to get windows 11 working on their X370 motherboard with a Ryzen 1600 processor.

I cleared cmos by removing the battery from the motherboard and unplugging the computer from all other power sources but it did not resolve the issue. 


I would like to see this board with working fTPM but I cannot find a way to get it working. Does anyone know of a way to fix this issue or is this a job for the bios software developers for this motherboard?


Level 7

Problem resolved. I had another Ryzen 2700 laying around so I replaced the 2700x with the 2700 and powered on the computer. screen I saw after the asus logo was something about the fTPM being corrupt and if I wanted to erase clear its keys/storage/whatever and I pressed Y. it then re-created the TPM for the 2700 and booted into windows. I then replaced the 2700 back to the 2700x and pressed y again when it showed the same message after showing the asus logo and it was able to boot to desktop.

So far, there have not been any more fTPM issues interfering with boot when fTPM is enabled. Problem solved.