cancel
Showing results for 
Search instead for 
Did you mean: 

Does CH7 Wi-Fi BIOS 2103 still have trouble with Corsair?

Stalkholm
Level 7
Since BIOS 1002 there has been a problem in which Corsair products connected via USB will disconnect and reconnect frequently and irritatingly. This has held true for me through the past four BIOS updates, including 2008.

Before I go through the trouble of updating my BIOS, updating my settings, booting into Windows, discovering that the problem is still there, doing a BIOS flashback, resetting my settings, then waiting another month for an update... can anybody save me the trouble and tell me whether Corsair coolers are still doing the disconnect/reconnect thing? I just- I'm just tired of doing the old song and dance, I'd rather skip it this time if I can.
584 Views
4 REPLIES 4

Zefram
Level 10
probably not helpful, but my config never had those issues on any of the bioses or any version of icue. just lucky, i guess.

Zefram wrote:
probably not helpful, but my config never had those issues on any of the bioses or any version of icue. just lucky, i guess.


I know; I think you tell me that after every update. 😛

I have never been able to get iCue to work either. The hardware works as normal without the software so I have resorted to that. With my peripherals, I set the profiles on another PC and then brought them back so I didn't have to install iCue. It is not something we should need to do but is a bandaid fix for now. Hopefully the problem is resolved soon. It has been quite some time.

Rufinoman
Level 8
I'm still on 0804 bios and I was getting the disconnect problem with a new H100i RGB Platinum I fitted a few weeks ago.
Anyway, Corsair are aware of this issue and have released a closed beta version of iCUE which has fixed the disconnect problem, for me and many others.
I sent a PM to James at Corsair (you can find him on the forum) and he sent me a link for the beta.
http://forum.corsair.com/forums/showthread.php?t=184745&page=3