Showing results for 
Search instead for 
Did you mean: 

Crosshair viii Extreme problems

Level 8

Where to start Lol..

1. Is there anyway to increase the brightness of the m.2 LiveDash, I have been searching for ages..

2. Thunderbolt drivers all loaded, top one at the rear works (but not correct speed). The top front panel connector not working, but bottom USBc one does? Top USB 3 header not working either.. I have got pcie cable in the header for power to the Thunderbolt connectors..

3. Can't get anything sound from the rear audio, if I pull out the speaker cable I get crackling through speakers, so there is power there.. Why are there no Audio drivers on the support download page?

This is a really expensive board, so you would think it would at least work properly..

Everything else is as normal..



Hello Vialli

Check device manager, this will show any drivers you need.

The Realtek Audio Driver is listed under windows 10, select windows 10 in the link below.

ROG Crosshair VIII Extreme (






Level 8

Hi Nate,

All the drivers and Realtek Audio Console are present..

It doesn't show Realtek in the Device manager under Audio devices?

Thanks for your advice..




You're welcome

Are your speakers working after installing the Realtek Audio driver? You can check to see they're set as the default device.

Press the windows key + R and type in mmsys.cpl and click OK.

On the Playback tab, check your speakers are set as the default device. I'm using the ROG Delta S Animate headset.

Default Device.png

Realtek Audio should show in device manager under    Sound, video and game controllers.

Realtek Audio driver.png



Drivers and the Audio Console are installed, but nothing in device manager..

I also have unknown USB device (Device descriptor Request Failed) , but that is port 2 asmedia USB 3.20 eXtensible host controller.. It also says driver problem, but port one is fine?



This can be caused by a number of things and could possibly be one of your usb devices.

There are 10 ways to fix this particular problem in this article.

I'd problably skip step 4.

10 Ways to Fix “Unknown USB Device (Device Descriptor Request Failed)” (


Cheers for the suggestions Nate,

I tried all of those things already, if I turn off asmedia USB 3.2 in bios the Unknown USB disappears but USB-c at rear still  works only 1 port though (same as with it enabled).. I think the sound and thunderbolt problems must a hardware failure.

The sound issue I think is also hardware, as the front sound is not working either? It seems the drivers and programmes are there, but the hardware isn't..



All right, try this.

1) Open command prompt as an administrator.

2) Type in msdt.exe -id devicediagnostic

3) Hit Enter

4) This will bring up the windows Hardware and Devices Troubleshooter.

5) Click Next to run the troubleshooter.

Does it find anything?


Yes the USB device (Device descriptor Request Failed)..

I had tried that already, over and over with no luck..

I spent 5 hours last night trying different things, with no luck..

When I get some time, I will take the board out and check it over..

Thanks for your help, not sure if it will work properly again..


At the ASUS Support Center under Bios & Firmware, there is a Thunderbolt Firmware downgrade for Thunderbolt 2 devices.

You could try this as well as updating/reflashing the bios.

ROG Crosshair VIII Extreme (