cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair VII Hero (WiFi) - Cannot see M.2 SSD in Windows 10

Oldar
Level 7
Hello there to all!

I wanted to ask you about a problem I am encountering. I recently did a clean windows 10 install on my system. Specs are below:

- Crosshair VII Hero (WiFi)
- Samsung 850 Pro SSD (OS)
- 2 x WD Raptor 300GB (RAID 0)
- ADATA XPG Gammix S11 pro SSD

While I was in the Windows installation menu, I loaded the right drivers for RAID, that this mobo needs, and I could see all my drives there (SSD, HDD, M.2). When I entered for the very first time in the windows 10, I was able to see in the Device Manager all the Disks again no problems. I set up the mapping letters everything seemed to be fine.

I then started to install drivers: chipset, sata, lan, audio etc. After my first restart I never saw the M.2 disk.

Can someone have an idea what happened? I even removed all the other disks and I was able to install Windows 10 into M.2 without issues again, but I want to have my OS to my first SSD as the M.2 will have other data in there.

After a little research I found out that in the Device Manager in the Storage Controllers there should be an entry "Standard MNM Express Controller" which I have not. My best guess is that some of the mobo's and AMD RAID drivers removed that entry and that is why I cannot see it anymore. I searched for some seperate NVMe drivers but I find nothing.

I tried to remove the M.2 disk from the slot and install it back but no luck. I can see it in the BIOS if I enable the CSM option, so has been installed alright, but I cannot see it in the Windows.

Any suggestions?

Friendly
Oldar
3,684 Views
8 REPLIES 8

raju2529
Level 7
your SSD has sata port or NVMe port . normal M.2 sata does nor need any special drivers
disable RAID option in bios
enable ACHI in sata controller in bios, it will detect automatically under
IDE ata/ atapi controllers
ssd can be sen under Diskdrives.


install Intel Rapaid storage technology driver 17.8.1.1066.
Intel i5 7200U_ Nvidia 940MX _Windows_11_Enterprise_64bit_22H2_buildno_22621.754

Oldar
Level 7
Thank you for your answer.

I know M.2 disks do not need special drivers and that is the odd thing. Although the system recognised it the first time I logged in, suddenly after the needed restarts I had to do in order to install the drivers from the other devices I lost the disk!

Please forgive my ignorance, but aren't the Intel Rapid Storage Technology for systems based on Intel CPU? I have already installed RAIDExpert2 from AMD. Do you think these 2 will have a confict each other?

I will try your solution in BIOS and I will report here.

If you have AMD based processor. Then don't install intel drivers. Because it Will conflict.
Is M.2 SSD is formatted with GPT disks tell me ?
Intel i5 7200U_ Nvidia 940MX _Windows_11_Enterprise_64bit_22H2_buildno_22621.754

Oldar
Level 7
Ok I did your steps you recommended, and when I disabled RAID to ACHI, I was unable to see the M.2 above all the other disks. I was reading "M.2 -> Empty" or something like that BUT when I change CSM to Auto or Enable then I can set in the Boot Options if I want to boot from M.2 so, I am not sure if that is logical to happen but BIOS somehow recognises the M.2 and still windows fail to see it. In addition to that when Sata Mode is set to AHCI if I want to enter windows, I get a blue screen saying "inaccesible storage device" or something like that. I need to have RAID on in order to enter windows.

I installed the program you mentioned but nothing changed...

Oldar
Level 7
At this point the disk is Unallocated as I used a USB Windows drive to check that it is installed as it should in my system and I can see it in there as an unallocated space.

I tried to enter windows in both RAID and AHCI mode in both Safe and Normal mode but nothing worked. I cannot see the M.2 in windows no matter what although I see it in BIOS under the BOOT options...

I tried to reinstall the AMD RAID Sata Drivers, nothing. But when I tried to unistall Chipset and Sata Raid drivers although I see them as installed programs in my windows apps menu, when I press "Unistall" a message warns me "No unistallable drivers found". Only the AMD GPU drivers I can unistall succesful...

https://www.xpg.com/us/feature/596/#Download

Try the SSD Toobox and see if it installs drivers for your ADATA NVMe.

Oldar
Level 7
After I lost my patience I did several clean installs (maybe three or four of them - I really lost count at this point). In my last one I managed to figure out that for some reason the most recent AMD RAID SATA NVMe Drivers was showing a message I really didn't noticed before. In order to see a NVMe disk in Windows 10 I need to enable the NVMe Raid Mode from BIOS. Although in my latest stable set up I had it disable and everything was working as intended, I fell for that illusion and I simply did not pay attention to that message.

Thank you very much for your time and your efforts to enlighten me friend!

You are most welcome. Ironically, the reason I had asked about the type of NVME SSD is because I was thinking about NVME Raid. My setup has 2xWDS512G1X0C in Raid0 and WDC WD5000AADS in Raid. For storage I use WDC WD2002FAEX. NVME is enabled. My motherboard is a Crosshair VI Extreme. Lets hope your problem is now solved. Remember to install RaidXpert.

Best Regards,
Fortiscrew.