cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair Vi Hero DTS & Dolby Audio Driver Fixed

Lord_Chunks
Level 7
Crosshair Vi Hero DTS & Dolby Audio Driver Fixed
-------------------------------------------------------------
Necacom Catalog PC Drivers
-------------------------------------------------------------
necacom Post Latest Drivers
Realtek High Definition Audio (HDA)....
-------------------------------------------------------------
https://necacom.net/index.php/realtek/hda
-------------------------------------------------------------
https://1drv.ms/u/s!Ao-k31O1onq_gtNfVVFl1ZR08gMg_A

RltkAPO64.dll
Take Said file and put in driver folder (Win64) you download from necacom then run setup.exe
Just repeat that everytime a new driver comes out. (Check Necacom They update alot)

-------------------------------------------------------------
This will work for other motherboards too... the file will work on anything realtek 64bit any verion of driver. find your driver and replace file

Supporting Realtek audio chips
ALC1220, ALC1150, ALC882, ALC883, ALC885, ALC886, ALC887, ALC888, ALC889, ALC892, ALC899, ALC861VD, ALC891, ALC900, ALC660, ALC662, ALC663, ALC665, ALC667, ALC668, ALC670, ALC671, ALC672, ALC676, ALC680, ALC221, ALC231, ALC233, ALC235, ALC236, ALC255, ALC256, ALC260, ALC262, ALC267, ALC268, ALC269, ALC270, ALC272, ALC273, ALC275, ALC276, ALC280, ALC282, ALC283, ALC284, ALC286, ALC288, ALC290, ALC292, ALC293, ALC298, ALC383

-------------------------------------------------------------
Can igonor Below just older Drivers OR As you will...
-------------------------------------------------------------
Sonic Studio 3 and Sonic Radar 3 not work with the drivers. Microsoft update catalog reltek drivers are missing the code for it to work.
-------------------------------------------------------------
Microsoft Update Catalog Realtek Drivers - No Asus Software Only Realtek HD Audio Manager + Driver
-------------------------------------------------------------

Install Guide Catalog Realtek Drivers: Extract Rar - Go to Device Manager (Windows key + R devmgmt.msc Enter - under sound, video and game conteoller (4th From Bottom click drop down) - double click Realtek High Definition Audio - Driver Tab - update driver (Button) - Browse My compter for driver software - clcik browse and find the extracted folder from earlier, select it single click press ok (Button) - click next - pop up click install - click ok - reboot.

Try Installing Newest Driver First at top of post - make sure windows 10 is up to date


-------------------------------------------------------------

Last Updated: May 15, 2018

DRIVER VERSION: 6.0.1.8447

(Only 64-bit Windows 10 Version 1803)

https://1drv.ms/u/s!Ao-k31O1onq_gthh9G2Nnbc7NVsmGw

-------------------------------------------------------------

Last Updated:
April 10, 2018

DRIVER VERSION: 6.0.1.8419

(Only 64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtgLUQn2rlAG_zdpDA

-------------------------------------------------------------


Last Updated:
March 6th 2018

DRIVER VERSION: 6.0.1.8393

(64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtU3HJxW2cC7YeYoKw

-------------------------------------------------------------

Last Updated:
February 27th 2018

DRIVER VERSION: 6.0.1.8383

(64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtUvz_0gAhywwvNBMQ

-------------------------------------------------------------

Aduio Driver Fix for DTS and Dolby Digital

Last Updated: February 6th 2018
DRIVER VERSION: 6.0.1.8366
(Only 64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtRImK1tn67GvVbpQA

-------------------------------------------------------------
Last Updated: January 23rd 2018
DRIVER VERSION: 6.0.1.8356
(Only 64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtNxavcF7PjMubZtHQ

-------------------------------------------------------------
Asus setup with Microsoft Update Catalog Realtek Drivers
-------------------------------------------------------------

Install Guide uninstall current driver -reboot

Extract Rar - run asussetup wait- click ok on pop two times - cmd disapear - reboot - enjoy.

-------------------------------------------------------------

Last Updated: January 16th 2018
DRIVER VERSION: 6.0.1.8351
(Only 64-bit Windows 10)

https://1drv.ms/u/s!Ao-k31O1onq_gtNglPWrOIifC7d1Og

-------------------------------------------------------------

Last Updated: January 5th 2018
DRIVER VERSION: 6.0.1.8341

https://1drv.ms/u/s!Ao-k31O1onq_gtNVtOyjyCfmPOlqxw

-------------------------------------------------------------

realtek high definition audio
driver 6.0.1.8295

https://1drv.ms/u/s!Ao-k31O1onq_gtFPkh7Nq4cmUVDmxQ

-------------------------------------------------------------
Crosshair Vi Hero Support Page Drivers
-------------------------------------------------------------

Version 6.0.1.8339 2018/02/27754.74 MBytesRealtek Audio Drive
Realtek Audio Driver V6.0.1.8339
Updated Amplify Level behavior to prevent overwriting manual adjustments upon reboot or resume from sleep/hibernation.

https://1drv.ms/u/s!Ao-k31O1onq_gthkk5VdFrVzMZ-pjg

-------------------------------------------------------------

Version 8090 2017/04/27459.48 MBytesAudio Driver
Add RS2 support for Sonic Studio 3 and Sonic Radar 3.

https://1drv.ms/u/s!Ao-k31O1onq_gsMgjcft2inlFiuRkg

-------------------------------------------------------------
Install Guide

69142

For spdif optical cable 5.1 surround dts interactive and Dolby digital live also dolby pro logic 2 shows no idea if it works.
also the drivers are signed

Steps to install
uninstall old drivers reboot
0. Run Asussetup.exe
69143
1. message pop twice - click ok both - Just Trying to install sonic studio - and sonic radar - stop em from installing you have to do manual if you want.
69144
2. when cmd disapear shortly after clicking ok - reboot
3. open realtek hd audio manager - click defualt tab - click the button dts and dolby a few times - Nothing Change - Reboot Again
69146
69145
4 step 3 will now work
69147
69148
69149
enjoy

:cool:
831 Views
40 REPLIES 40

It turns out its not as complicated as it first looks. At least, if you're interested in DTSi, DDL, and also Dolby Theater process for stereo sources. There's no weird hacking necessary of unsigned drivers. It just works the way it was meant to. Just use the Microsoft Catalog driver at the bottom cleanly (installing the Asus setup first). It's the latest WHQL'ed Microsoft driver shipped with the latest Windows update.

If you want to add the extra software suite (which IMO just bloats your system), then you'll have to go through hoops to use the hacked experimental drivers and change your OS boot options to support unsigned drivers.

Anyway, good luck in whatever you end up doing. Im just glad we have this forum thread as a resource. It saved me from having to waste my money on another sound card.

a.l.timmons wrote:
Yea, I am trying to figure this out now too. This whole process is opaque as hell. Never really explained.

Summary: TL; DR, there seems to be 3 options-

The cracked OEM Driver here, where newest is at the top

A cracked version on tech power up that also includes other software- (Some sound blaster stuff)
https://www.techpowerup.com/forums/threads/unlocked-realtek-hd-audio-drivers-windows-7-8-with-dolby-...
- really confusing there too- 112 pages of banter to pick through. Its always hard. Start at the end and go backwards- nothing makes sense but you dont miss the critical update on page 49. Or at the beginning, and understand, but be 4 years behind.

Theres also a replace patch that seems to replace 2 files in the system directory. https://www.techpowerup.com/forums/threads/unlocked-realtek-hd-audio-drivers-windows-7-8-with-dolby-...

So, I haven't figured out differences yet, or even if it makes sense for me to do this. I don't use digital output. I don't have any headphones yet that are worthy.

Several of those guys link over here.

any new updates on the latest driver? much appreciated

Calibos
Level 7
Arrgh. Been pulling my hair out the last few days with all the hacked driver malarley and hoped that this thread was my salvation.

I've an Asus Z170-A mobo running windows 10 April update. I recently bought a new Receiver for the livingroom Home theater which freed up an old Sony DB930 Receiver for my PC/VR room. I bought myself a lovely KEF E305 (Eggs) 5.1 Speaker system. My intention was for the Realtek Integrated audio chipset on my mobo to do all the encoding/decoding work and feed the old Sony Receiver the 5.1 channel analogue signal, effeectively only using the Receivers Amplification and not using its old Dolby Digital or Pro Logic 1 decoder over optical/Toslink. The latest HD audio formats like Dolby TrueHD and ATMOS are only possible over the analogue outputs anyway. So I can play TrueHD etc movie soundtracks via Kodi and my Realtek 5.1 analogue outputs, through the 5.1 speaker inputs of my old receiver. Worked as expected. Great!! However I was frustrated to find that the Realtek drivers did not support Psuedo Multi-Channel like Dolby Pro Logic 2 for Stereo sources. Thats what sent me down the hacked drivers rabbit hole from which I only have just recovered. Nothin workedf needless to say.

I thought my salvation was here. Have deleted all evidence of the hacked drivers I installed the drivers here with Asussetup and then the latest MS catalogue drivers. My problem now is that while I have the Dolby Pro logic 2 tab when I tick the box the Apply button remains grey'd out and I cannot click it. Not only that but with these drivers I lost the Bass management tickbox on the Realtek app and while my subwoofer works when clicking the speaker icon test tones, when I play 2 channel audio content like a youtube vid, not only am I not getting Pro Logic 2 Psuedo Multichannel, I'm only getting Front left and Right Stereo 2.0 but my Subwoofer isn't outputting any sound either so I'm not even getting 2.1 nevermind 5.1.

Literally all I want from the realtek drivers that I didn't have as standard is Pro Logic 2 Psuedo Multichannel for stereo sources like music or 2 Channel Movie/TV Shows outputting over the Realteks analogue 5.1 outputs to my old receiver.

Can anyone help. I'm pulling my hair out at this stage!!

[EDIT] Sorted it myself....by reverting back to standard drivers. Turns out the included DTS NEO PC DTS Connect does exactly what I want and the reason it was having no effect on the sound was that I was using Youtube on Chrome. WHen I finally demo'd a stereo movie file on my PC all of a sudden I was getting sound coming from my Centre and rears. Then I tried the youtube music vids again but in Microsoft Edge browser this time and DTS Neo PC was working on that too with sound coming from all my speakers. So I knew it wasn't a problem with my realtek drivers nor with youtube but bloody Chrome!!!

Turns out there is a bug in Chrome that outputs a 5.1 flag even when the audio file playing in chrome is only stereo. What this flag does is tell DTS NEO PC that it need not do its Psuedo Surround thing because a genuine 5.1 file is playing....except of course its only 2.0 but the flag stops Neo PC. First results for a solution was to add --force-wave-audio to the Chrome shortcut target but then readf posts from people saying that Google had broken that method too with an update last year. Finally found a working fix.

Type chrome://flags/ into your chrome address bar. You get a page called experiments use at your own risk blah blah

In the Search Flags search bar enter: Causes audio output streams to check if channel layouts other than the default hardware layout are available.

Enable

(Causes audio output streams to check if channel layouts other than the default hardware layout are available. Turning this on will allow the OS to do stereo to surround expansion if supported. May expose third party driver bugs, use with caution. – Windows)

Thats it. DTS NEO PC now worked on youtube in chrome with Psuedo 5.1 coming from all my speakers. Thats all I ever bloody wanted and it was always available to me in the standard drivers all this time it just wouldn't work because of a bug in Bloody Chrome!!! Wasted days on this!!

Calibos wrote:
Arrgh. Been pulling my hair out the last few days with all the hacked driver malarley and hoped that this thread was my salvation.

I've an Asus Z170-A mobo running windows 10 April update. I recently bought a new Receiver for the livingroom Home theater which freed up an old Sony DB930 Receiver for my PC/VR room. I bought myself a lovely KEF E305 (Eggs) 5.1 Speaker system. My intention was for the Realtek Integrated audio chipset on my mobo to do all the encoding/decoding work and feed the old Sony Receiver the 5.1 channel analogue signal, effeectively only using the Receivers Amplification and not using its old Dolby Digital or Pro Logic 1 decoder over optical/Toslink. The latest HD audio formats like Dolby TrueHD and ATMOS are only possible over the analogue outputs anyway. So I can play TrueHD etc movie soundtracks via Kodi and my Realtek 5.1 analogue outputs, through the 5.1 speaker inputs of my old receiver. Worked as expected. Great!! However I was frustrated to find that the Realtek drivers did not support Psuedo Multi-Channel like Dolby Pro Logic 2 for Stereo sources. Thats what sent me down the hacked drivers rabbit hole from which I only have just recovered. Nothin workedf needless to say.

I thought my salvation was here. Have deleted all evidence of the hacked drivers I installed the drivers here with Asussetup and then the latest MS catalogue drivers. My problem now is that while I have the Dolby Pro logic 2 tab when I tick the box the Apply button remains grey'd out and I cannot click it. Not only that but with these drivers I lost the Bass management tickbox on the Realtek app and while my subwoofer works when clicking the speaker icon test tones, when I play 2 channel audio content like a youtube vid, not only am I not getting Pro Logic 2 Psuedo Multichannel, I'm only getting Front left and Right Stereo 2.0 but my Subwoofer isn't outputting any sound either so I'm not even getting 2.1 nevermind 5.1.

Literally all I want from the realtek drivers that I didn't have as standard is Pro Logic 2 Psuedo Multichannel for stereo sources like music or 2 Channel Movie/TV Shows outputting over the Realteks analogue 5.1 outputs to my old receiver.

Can anyone help. I'm pulling my hair out at this stage!!

[EDIT] Sorted it myself....by reverting back to standard drivers. Turns out the included DTS NEO PC DTS Connect does exactly what I want and the reason it was having no effect on the sound was that I was using Youtube on Chrome. WHen I finally demo'd a stereo movie file on my PC all of a sudden I was getting sound coming from my Centre and rears. Then I tried the youtube music vids again but in Microsoft Edge browser this time and DTS Neo PC was working on that too with sound coming from all my speakers. So I knew it wasn't a problem with my realtek drivers nor with youtube but bloody Chrome!!!

Turns out there is a bug in Chrome that outputs a 5.1 flag even when the audio file playing in chrome is only stereo. What this flag does is tell DTS NEO PC that it need not do its Psuedo Surround thing because a genuine 5.1 file is playing....except of course its only 2.0 but the flag stops Neo PC. First results for a solution was to add --force-wave-audio to the Chrome shortcut target but then readf posts from people saying that Google had broken that method too with an update last year. Finally found a working fix.

Type chrome://flags/ into your chrome address bar. You get a page called experiments use at your own risk blah blah

In the Search Flags search bar enter: Causes audio output streams to check if channel layouts other than the default hardware layout are available.

Enable

(Causes audio output streams to check if channel layouts other than the default hardware layout are available. Turning this on will allow the OS to do stereo to surround expansion if supported. May expose third party driver bugs, use with caution. – Windows)

Thats it. DTS NEO PC now worked on youtube in chrome with Psuedo 5.1 coming from all my speakers. Thats all I ever bloody wanted and it was always available to me in the standard drivers all this time it just wouldn't work because of a bug in Bloody Chrome!!! Wasted days on this!!


Actually I suggest that you uninstall your Realtek Driver using Revo Uninstaller to get rid of all registry entries and turn back on digital signature enforcement on drivers if you are using Windows 10 Windows 8 since you had to turn it off to get the modded Realtek driver to work. Then reinstall Realtek drivers again from ASUS website or from other websites. If you are still interested in Dolby Pro Logic II all you need is the RltkAPO64.dll from the latest driver posted by 'Lord Chunks' and copy it to system32 folder also RltkAPO.dll to sysWOW64 (while you are in safe mode because it will keep saying file in use), and that is it. Anyway your motherboard already support DTS Connect and DTS Studio Sound. Studio Sound is similar to Dolby Pro Logic II I think, but I think you need the Realtek Drivers by ASUS to enable these.

rubenalamina
Level 7
Any new drivers? I lost track of these but the latest one if from May.

No DTS or Dolby, but these drivers are awesome:

https://dlcdnets.asus.com/pub/ASUS/mb/01AUDIO/Realtek_Audio_Driver_With_NAHIMIC_WIN10-64_V6.0.1.8507...

(From Maximus XI Extreme page. The board uses same realtek chip, so...)

Hurricane28
Level 10
Nice!

I guess this also works on the C7H? It has the same codec. Thnx.

Hurricane28 wrote:
Nice!

I guess this also works on the C7H? It has the same codec. Thnx.


Works like a charm here. I am able to tell: big sound quality boost.

Hurricane28
Level 10
Cool! Now, which driver do i have to use? I can't figure out which one i need.. Thnx.

Lord_Chunks
Level 7




#
+-+ +-+ +-+ +-+ +-+ +-+
# |U| |p| |d| |a| |t| |e|
# +-+ +-+ +-+ +-+ +-+ +-+