cancel
Showing results for 
Search instead for 
Did you mean: 

Corsair problems persist on CH7WIFI 2203

Stalkholm
Level 7
Yep, I'm running the latest iCUE software, yes I've tried powering off my computer and unplugging it, yes I've tried reinstalling the software. This has been a problem on all BIOS later than 1002.

If it was going to be fixed it would have been fixed by now, I'm just posting this so other folks will know.
2,310 Views
7 REPLIES 7

Tunza
Level 7
I have been waiting a very long time just as you have. TBH you were lucky it worked in 1002. I have tried all the 1xxx BIOS and the BIOS 2304 but nothing. In fact, all anything above 1002 gave me worse performance and iCUE still did not work correctly. Is it periferals or fans/coolers/ram you are trying to use? As long as I DISABLE iCUE on startup, don't run any monitoring tools (check background apps) and manually open iCue everything is detected. Unfortunatley you have to close it once you are done so no profiles continue to run. It is good for setting your fans though and then shut down. PAIN IN THE BUM THOUGH.

I feel your pain man. If I had known my Corsair gear was gonna be this bad I probably woulda gone for MSI's 'trophy' X470 instead. who knows though. Asus blame AMD, AMD blame Asus, Corsar Blame Asus, etc etc.

Good luck with it all. youll need it

Tunza Down Unda 😛

Same issue except non wifi CH7. Last working bios for me was 0804. I rolled back two days ago to 0804 to diagnose ram issues and sure enough first boot into windows all the corsair devices picked up.

Sorted my ram problem and flashed back to 2203 and yep "device descriptor request failed"

regardless of whose fault it ends up being ASUS should at the very least be working with Corsair to get the issues resolved whether that comes in the form of a bios update or icue update...

Baio73
Level 8
New iCue version on the road… 3.16.56.
Hope this may help.

Baio
CASE Lian Li 011D XL CPU AMD Ryzen 7950X3D COOLER Corsair H150i Elite Capellix MOBO Asus ROG Strix X670E-A Gaming Wifi RAM 2x16Gb Corsair Dominator Titanium 6000 [CMP32GX5M2B6000Z30] PSU Asus Thor 1200P VGA Asus ROG Strix RX 6900XT DISPLAY LG 34GK950GF AUDIO Logitech G560 SDD NVMe WD Black SN850 4Tb INPUT Logitech Pro wireless + Powerplay + Corsair MM 700 RGB - Corsair K100

Sorry to hear that you guys are still having issues. I was one of the first people to report issues with Asus BIOS and iCUE, but all my issues have long since been resolved after one of the iCUE updates. I'm running 2304 and no complaints. Good luck to you who are still having problems.

Yep latest BIOS latest Icue 3.16, still not detected 😞

I've made a thread asking if the same issue will happen on the CH8. I am already looking at a platform upgrade for PCIE 4.0, so if CH8 has the same issue I'll just go MSI.

Try bumping up the SoC voltage using (+) offset. That's how I got mine to work.