Showing results for 
Search instead for 
Did you mean: 

Can't update my Crosshair Formula VIII X570 to any bios after version 1001

Level 7
So I bought a R9 5900X. When I tried to update my bios, and I didn't update since the first assembly, the MOBO message was "installation sucefully", but, when I tried to boot, got code 92 error. Just to be clear, I've tried EVERY single version since 502. Any version after 1001 give the same error. Tried various methods of update: Through bios software, by Windows, by pendrive with the ezflash and so on. Tried to remove memory sticks, change slots, with/without the old processor, and with the new one as well. Asus support doesnt kwon what to do either. The R9 is working perfectly in my test bench, so its not one to blame either. I need coffee and help...

ThomasDSC wrote:
I bought the R9 5900X but cant use because my mobo wont update. Thats why I need help.

You're saying it won't update BIOS using the flash method, which I find hard to believe and tell you why. I have owned ROG motherboards (ASUS ROG Rampage III Gene X58 Micro ATX ) and I think this was one of the first to have Asus USB flashback (8-10 years ago) and since then, on ASUS motherboards with this feature, I have had corrupted BIOS, BIOS actually fail due to power out while flashing (insta BRICKING for all other type of motherboards) and through using USB flashback, I have always been able to use USB flashback to fix everything, update or downgrade BIOS without issue following the guides given by ASUS and using a valid BIOS for the motherboard.

I thought (possibly wrongly) you were upgrading from from earlier Ryzen CPU because you mention 1-year warranty and the inability to RMA the motherboard and what I was suggesting is if you have the Ryzen 3000 series CPU, you could try what I mentioned to update it rather than USB Flash method (which is assuming you have 3000 series CPU or don't understand why you cant RMA motherboard, how is it older than CPU and you don't have an older CPU for it ?).

The 5900x will not work or BOOT with 1001 BIOS, it does not matter what the error code is. Only a 2311 BIOS version or latter will BOOT and not end in failure qcode.

Also your using dot method for TIM on the CPU, this is not the recommended application method for an AMD CPU. While not source issue, just annoyes me to see Intel TIM application method used on AMD CPU.

Hope you find this helpful.

RedSector73 wrote:
If you can boot 1001 BIOS, why not update to the latest from within the BIOS ?

Actually, the bios is successfully updated, but won't boot. I've tried every method. Doesn't work.